...

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z


Glossary

Symbols

(All) level

The optional highest level of a dimension. The (All) level contains a single member that is the summary of all members of the immediately subordinate level.

A

action

An end user-initiated operation upon a selected cube or portion of a cube. The operation can launch an application with the selected item as a parameter or retrieve information about the selected item.

active statement

An SQL statement that has been executed but whose result set has not yet been canceled or fully processed.

active voice

Indicates the subject of the sentence is the entity that performs the action described by the verb. For example, customers buy products is in active voice, whereas products are bought by customers is in passive voice.

See also: passive voice

ActiveX Data Objects

An easy-to-use application programming interface (API) that wraps OLE DB for use in languages such as Visual Basic, Visual Basic for Applications, Active Server Pages, and Microsoft Internet Explorer Visual Basic Scripting.

ActiveX Data Objects (Multidimensional) (ADO MD)

A high-level, language-independent set of object-based data access interfaces optimized for multidimensional data applications. Visual Basic and other automation languages use ADO MD as the data access interface to multidimensional data storage. ADO MD is a part of ADO 2.0 and later.

ad hoc connector name

The OpenRowset function in the FROM clause of a query, which allows all connection information for an external server and data source to be issued every time the data must be accessed.

add-in

A custom extension, written in any language that supports the Component Object Model (COM), usually Visual Basic, that interacts with Analysis Manager and provides specific functionality. Add-ins are registered with the Analysis Add-in Manager. They are called by the Analysis Add-in Manager in response to user actions in the user interface.

adjective phrasing

A way of expressing a relationship in English in which an entity is described by an adjective (either a single word or another entity containing the adjective). For example, in the phrasing the cities are hot, hot is the adjective, and cities is the entity being described.

ADO

See definition for: ActiveX Data Objects

ADO MD

See definition for: ActiveX Data Objects (Multidimensional) (ADO MD)

adverb

The part of speech modifying a verb, an adjective, or another adverb. In English Query, adverbs such as very and recent are interpreted correctly; however, other adverbs, such as rapidly or graciously are not interpreted.

aggregate function

A functions that performs a calculation on a column in a set of rows and returns a single value.

aggregate query

A query (SQL statement) that summarizes information from multiple rows by including an aggregate function such as Sum or Avg .

aggregation

A table or structure that contains precalculated data for a cube.

aggregation

A collection of objects that makes a whole. An aggregation can be a concrete or conceptual set of whole-part relationships among objects.

aggregation prefix

A string that is combined with a system-defined ID to create a unique name for a partition's aggregation table.

aggregation wrapper

A wrapper that encapsulates a COM object within another COM object.

alert

A user-defined response to a SQL Server event. Alerts can either execute a defined task or send an e-mail and/or pager message to a specified operator.

alias

An alternative name for a table or column in expressions that is often used to shorten the name for subsequent reference in code, prevent possible ambiguous references, or provide a more descriptive name in the query output. An alias can also be an alternative name for a server.

aliasing

To allow the name of an object, property, or relationship to be reused in a new context while keeping all other attributes constant.

All member

The single member of the (All) level. By default, the name of the All member is All followed by a space and the dimension name.

See also: default member

American National Standards Institute (ANSI)

An organization of American industry and business groups that develops trade and communication standards for the United States. Through membership in the International Organization for Standardization (ISO) and the International Electrotechnical Commission (IEC), ANSI coordinates American standards with corresponding international standards.

Analysis server

The server component of Analysis Services that is specifically designed to create and maintain multidimensional data structures and provide multidimensional data in response to client queries.

ancestor

A member in a superior level in a dimension hierarchy that is related through lineage to the current member within the dimension hierarchy. For example, in a Time dimension containing the levels Quarter, Month, and Day, Qtr1 is an ancestor of January 1.

See also: parent, child, descendant, sibling

annotational property

A property that is maintained by Meta Data Services as string data that can be attached to any repository object that exposes the IAnnotationalProps interface.

anonymous subscription

An anonymous subscription is a type of pull subscription for which detailed information about the subscription and the Subscriber is not stored.

ANSI

See definition for: American National Standards Institute (ANSI)

ANSI to OEM conversion

The conversion of characters that must occur when data is transferred from a database that stores character data using a specific code page to a client application on a computer that uses a different code page. Typically, Windows-based client computers use ANSI/ISO code pages, and some databases (for compatibility reasons) may use OEM code pages, such as the MS-DOS 437 code page or code page 850.

API

See definition for: application programming interface (API)

API server cursor

A server cursor built to support the cursor functions of an application programming interface (API), such as ODBC, OLE DB, ADO, and DB-Library. An application does not usually request a server cursor directly; it calls the cursor functions of the API. The SQL Server interface for that API implements a server cursor if that is the best way to support the requested cursor functionality.

See also: server cursor

application programming interface (API)

A set of routines available in an application, such as ADO, for use by software programmers when designing an application interface.

application role

A SQL Server role created to support the security needs of an application.

archive file

The .cab file created by archiving an Analysis Services database.

article

An object specified for replication. An article is a component in a publication and can be a table, specified columns (using a column filter), specified rows (using a row filter), a stored procedure or view definition, the execution of a stored procedure, a view, an indexed view, or a user-defined function.

atomic

Either all of the transaction data modifications are performed or none of them are performed.

attribute

In data mining, a single characteristic of a case. Attributes are used to provide information about a case. For example, weight can be an attribute of a case that involves shipping containers.

See also: case

authentication

The process of validating that the user attempting to connect to SQL Server is authorized to do so.

See also: SQL Server Authentication

authorization

The operation that verifies the permissions and access rights granted to a user.

automatic recovery

Recovery that occurs every time SQL Server is restarted. Automatic recovery protects your database if there is a system failure.

autonomy

The independence one site has from other sites when performing modifications to data.

axis

A set of tuples. Each tuple is a vector of members. A set of axes defines the coordinates of a multidimensional data set. For more information about axes, see the OLE DB documentation.

See also: slice, tuple

B

backup

A copy of a database, transaction log, file, or filegroup used to recover data after a system failure.

backup device

A tape or disk used in a backup or restore operation.

backup file

A file that stores a full or partial database, transaction log, or file and/or filegroup backup.

backup media

The tape, disk, or named pipe used to store a backup set.

backup set

The output of a single backup operation.

balanced hierarchy

A dimension hierarchy in which all leaf nodes are the same distance from the root node.

base data type

Any system-supplied data type, for example, char , varchar , binary , and varbinary . User-defined data types are derived from base data types.

See also: data type, user-defined data type

base table

A table stored permanently in a database. Base tables are referenced by views, cursors, SQL statements, and stored procedures.

See also: underlying table

batch

A set of SQL statements submitted together and executed as a group. A script is often a series of batches submitted one after the other.

bcp files

Files that store bulk copy data created by the bulk copy utility or synchronization.

bcp utility

A command prompt bulk copy utility that copies SQL Server data to or from an operating system file in a user-specified format.

bigint data type

An integer data type with a value from -2^63 (-9223372036854775808) through 2^63-1 (9223372036854775807).

binary data type

A fixed-length binary data type with a maximum length of 8,000 bytes.

binary large object

A piece of binary data that has an exceptionally large size (such as pictures or audio tracks stored as digital data), or any variable or table column large enough to hold such values. In Transact-SQL, a BLOB is stored in an image column. Sometimes the term BLOB is also applied to large character data values, such as those stored in text or ntext columns.

binding

In SQL application programming interfaces (APIs), binding is associating a result set column or a parameter with a program variable so that data is moved automatically into or out of a program variable when a row is fetched or updated.

bit data type

A data type that holds a value of either 1 or 0.

bitwise operation

An operation that manipulates a single bit, or tests whether a bit is on or off.

BLOB

See definition for: binary large object

blocks

A series of Transact-SQL statements enclosed by BEGIN and END. You can nest BEGIN...END blocks within other BEGIN...END blocks.

Boolean

An operation or expression that can be evaluated only as either true or false.

browse mode

A function that lets you scan database rows and update their values one row at a time. Several browse mode functions return information that an application can use to examine the structure of a complicated ad hoc query.

built-in functions

A group of predefined functions provided as part of the Transact-SQL and Multidimensional Expressions (MDX) languages.

business rules

The logical rules that are used to run a business. Business rules can be enforced in the .com objects that make up the middle tier of a Windows DNA system, they can also be enforced in a SQL Server database using triggers, stored procedures, and constraints.

C

cache aging

The mechanism of caching that determines when a cache row is outdated and must be refreshed.

calculated column

A column in a table that displays the result of an expression rather than stored data. For example, CalculatedCostColumn = Price * Quantity .

calculated field

A field defined in a query that displays the result of an expression rather than stored data.

calculated member

A member of a dimension whose value is calculated at run time using an expression. Calculated member values may be derived from other members' values. A calculated member is any member that is not an input member. For example, a calculated member Profit can be determined by subtracting the value of the member Costs from the value of the member Sales.

See also: input member

calculation condition

A Multidimensional Expressions (MDX) logical expression used to determine whether a calculation formula will be applied against a cell in a calculation subcube.

See also: solve order

calculation formula

A Multidimensional Expressions (MDX) expression used to supply a value for cells in a calculation subcube, subject to the application of a calculation condition.

See also: solve order

calculation pass

A stage of calculation in a multidimensional cube in which applicable calculations are evaluated. Multiple passes may be required to complete all calculations.

See also: solve order

calculation subcube

The set of multidimensional cube cells used to create a calculated cells definition. The set of cells is defined by a combination of Multidimensional Expressions (MDX) set expressions.

See also: solve order

call-level interface (CLI)

The interface supported by ODBC for use by an application.

candidate key

A column or set of columns that have a unique value for each row in a table. Each candidate key value uniquely identifies a single row in the table. Tables can have multiple candidate keys. One candidate key in a table is specified by the database designer to be the primary key for the table, and any other candidate key is called an alternate key.

cascading delete

An operation that deletes a row containing a primary key value that is referenced by foreign key columns in existing rows in other tables. On a cascade delete, all of the rows whose foreign key values reference the deleted primary key value are also deleted.

cascading update

An operation that updates a primary key value that is referenced by foreign key columns in existing rows in other tables. On a cascade update, all of the foreign key values are updated to match the new primary key value.

case

In data mining, an abstract view of data characterized by attributes and relations to other cases. A case is a distinct member of a case set, and can be a member of multiple case sets.

See also: case key, case set, attribute

case key

In data mining, the element of a case by which the case is referenced within a case set.

See also: case

case set

In data mining, a set of cases.

See also: case

cell

In a cube, the set of properties, including a value, specified by the intersection when one member is selected from each dimension.

cellset

In ADO MD, an object that contains a collection of cells selected from cubes or other cellsets by a multidimensional query.

certificate

A collection of data used for authentication and secure exchange of information on nonsecured networks, such as the Internet. A certificate securely binds a public encryption key to the entity that holds the corresponding private encryption key. Certificates are digitally signed by the issuing certification authority and can be managed for a user, a computer, or a service.

change script

A text file that contains SQL statements for all changes made to a database, in the order in which they were made, during an editing session. Each change script is saved in a separate text file with an .sql extension. Change scripts can be applied back to the database later, using a tool such as osql .

changing dimension

A dimension that has a flexible member structure. A changing dimension is designed to support frequent changes to structure and data.

char data type

A character data type that holds a maximum of 8,000 characters.

character format

Data stored in a bulk copy data file using text characters.

See also: native format

character set

A character set determines the types of characters that SQL Server recognizes in the char , varchar , and text data types. Each character set is a set of 256 letters, digits, and symbols specific to a country or language. The printable characters of the first 128 values are the same for all character sets. The last 128 characters, sometimes referred to as extended characters, are unique to each character set. A character set is related to, but separate from, Unicode characters.

CHECK constraints

Defines which data values are acceptable in a column. You can apply CHECK constraints to multiple columns, and you can apply multiple CHECK constraints to a single column. When a table is dropped, CHECK constraints are also dropped.

checkpoint

An event in which the database engine writes dirty buffer pages to disk. Dirty pages are pages that have been modified, but the modifications have not yet been written to disk. Each checkpoint writes to disk all pages that were dirty at the last checkpoint and still have not been written to disk. Checkpoints occur periodically based on the number of log records generated by data modifications, or when requested by a user or a system shutdown.

child

A member in the next lower level in a hierarchy that is directly related to the current member. For example, in a Time dimension containing the levels Quarter, Month, and Day, January is a child of Qtr1.

See also: ancestor, parent, descendant, sibling

classification

See definition for: prediction

clause

In English Query, a sequence of related words within a sentence, having both a subject and a predicate and functioning as either an independent or a dependent unit. In Transact-SQL, a subunit of an SQL statement. A clause begins with a keyword.

CLI

See definition for: call-level interface (CLI)

client application

An application that retrieves data from an Analysis server and performs local analysis and presentation of data from relational or multidimensional databases. Client applications connect to the Analysis server through the PivotTable Service component.

client cursor

A cursor implemented on the client. The entire result set is first transferred to the client, and the client application programming interface (API) software implements the cursor functionality from this cached result set.

clustered index

An index in which the logical order of the key values determines the physical order of the corresponding rows in a table.

clustering

A data mining technique that analyzes data to group records together according to their location within the multidimensional attribute space. Clustering is an unsupervised learning technique.

See also: segmentation

code page

For character and Unicode data, a definition of the bit patterns that represent specific letters, numbers, or symbols (such as 0x20 representing a blank space and 0x74 representing the character "t"). Some data types use 1 byte per character; each byte can have 1 of 256 different bit patterns.

collation

A set of rules that determines how data is compared, ordered, and presented. Character data is sorted using collation information, including locale, sort order, and case-sensitivity.

See also: locale, SQL collation

column

In an SQL table, the area in each row that stores the data value for some attribute of the object modeled by the table. For example, the Employees table in the Northwind sample database models the employees of the Northwind Traders company. The LastName column in each row of the Employees table stores the last name of the employee represented by that row, the same way a Last Name field in a window or form would contain a last name.

See also: row

column filter

Column filters restrict the columns to be included as part of a snapshot, transactional or merge publication.

column-level collation

The ability of SQL Server 2000 to support multiple collations in a single instance. Databases can have default collations different from the default collation of the instance. Individual columns and variables can be assigned collations different from the default collation for the instance or database. Each column in a table can have a different collation.

column-level constraint

A constraint definition that is specified within a column definition when a table is created or altered. The constraint applies only to the associated column.

See also: constraint

COM

See definition for: Component Object Model (COM)

COM-structured storage file

A component object model (COM) compound file used by Data Transformation Services (DTS) to store the version history of a saved DTS package.

command relationship

Provides instructions to hardware based on natural-language questions or commands. For example, "Play the album with song XXX on it."

commit

An operation that saves all changes to databases, cubes, or dimensions made since the start of a transaction. A commit guarantees that all of the transaction's modifications are made a permanent part of the database, cube or dimension. A commit also frees resources, such as locks, used by the transaction.

See also: roll back

comparative form

A form of an adjective or adverb that refers to a comparison or that denotes a greater degree. Shorter adjectives and some adverbs typically form their comparative degree by adding -er, such as young and younger.

Component Object Model (COM)

A Microsoft specification for developing component software. Several SQL Server and database application programming interfaces (APIs) such as SQL-DMO, OLE DB, and ADO are based on COM. Some SQL Server components, such as Analysis Services and English Query, store objects as COM objects.

See also: method

composite index

An index that uses more than one column in a table to index data.

composite key

A key composed of two or more columns.

computed column

A virtual column in a table whose value is computed at run time. The values in the column are not stored in the table, but are computed based on the expression that defines the column. An example of the definition of a computed column is: Cost as Price * Quantity .

concatenation

To combine two or more character strings or expressions into a single character string or expression, or to combine two or more binary strings or expressions into a single binary string or expression.

concurrency

A process that allows multiple users to access and change shared data at the same time. SQL Server uses locking to allow multiple users to access and change shared data at the same time without conflicting with each other.

conjunction

A part of speech (such as and or although) used to connect words, phrases, clauses, or sentences. Coordinating conjunctions (and, but, or, nor, for, so, yet) connect and relate words and word groups of equal grammatical rank.

connection

An interprocess communication (IPC) linkage established between a SQL Server 2000 application and an instance of SQL Server 2000. The connection is a network link if the application is on a computer different from the SQL Server 2000 instance. If the application and the SQL Server 2000 instance are on the same computer, the linkage is formed through a local IPC mechanism, such as shared memory. The application uses the IPC linkage to send Transact-SQL statements to SQL Server and to receive result sets, errors, and messages from SQL Server.

constant

A group of symbols that represent a specific data value. The format of a constant depends on the data type of the value it represents. For example, 'abc' is a character string constant, 123 is an integer constant, 'December 16, 1999' is a datetime constant, and 0x02FA is a binary constant.

constraint

A property assigned to a table column that prevents certain types of invalid data values from being placed in the column. For example, a UNIQUE or PRIMARY KEY constraint prevents you from inserting a value that is a duplicate of an existing value, a CHECK constraint prevents you from inserting a value that does not match a search condition, and NOT NULL prevents you from inserting a NULL value.

See also: column-level constraint

continuation media

The backup media used when the initial medium becomes full, allowing continuation of the backup operation.

control-break report

A report that summarizes data in user-defined groups or breaks. A new group is triggered when different data is encountered.

control-of-flow language

Transact-SQL keywords that control the flow of execution of SQL statements and statement blocks in triggers, stored procedures, and batches.

correlated subquery

A subquery that references a column in the outer statement. The inner query is executed for each candidate row in the outer statement.

CPU busy

A SQL Server statistic that reports the time, in milliseconds, the central processing unit (CPU) spent on SQL Server work.

crosstab query

Displays data for summarized values from a field or table, and then groups them by two sets of facts: one down the left side and the other across the top of the datasheet.

cube

A set of data that is organized and summarized into a multidimensional structure defined by a set of dimensions and measures.

See also: multidimensional structure

cube file

See definition for: local cube

cube role

A collection of users and groups with the same access to a cube. A cube role is created when you assign a database role to a cube, and it applies only to that cube.

See also: custom rule, database role

cursor

An entity that maps over a result set and establishes a position on a single row within the result set. After the cursor is positioned on a row, operations can be performed on that row, or on a block of rows starting at that position. The most common operation is to fetch (retrieve) the current row or block of rows.

cursor data type

A special data type used to reference a cursor.

cursor library

A part of the ODBC and DB-Library application programming interfaces (APIs) that implements client cursors. A cursor library is not commonly used in current systems; server cursors are used instead.

custom rollup

An aggregation calculation that is customized for a dimension level or member and overrides the aggregate functions of a cube's measures.

custom rule

In a role, a specification that limits the dimension members or cube cells that users in the role are permitted to access.

See also: cube role, database role

D

data block

In text , ntext , and image data, a data block is the unit of data transferred at one time between an application and an instance of SQL Server 2000. The term is also applied to the units of storage for these data types. In tape backup files, data block is the unit of physical I/O.

data connection

A collection of information required to access a specific database. The collection includes a data source name and logon information. Data connections are stored in a project and are activated when the user performs an action that requires access to the database. For example, a data connection for a SQL Server database consists of the name of the database, the location of the server on which it resides, network information used to access that server, and a user ID and password.

Data Control Language (DCL)

The subset of SQL statements used to control permissions on database objects. Permissions are controlled using the GRANT and REVOKE statements.

data definition

Specifying the attributes, properties, and objects in a database.

data definition language (DDL)

A language, usually part of a database management system, that is used to define all attributes and properties of a database, especially row layouts, column definitions, key columns (and sometimes keying methodology), file locations, and storage strategy.

data dictionary

A set of system tables, stored in a catalog, that includes definitions of database structures and related information, such as permissions.

data dictionary view

A system table.

data explosion

The exponential growth in size of a multidimensional structure, such as a cube, due to the storage of aggregated data.

See also: density, sparsity

data file

In bulk copy operations, the file that transfers data from the bulk copy out operation to the bulk copy in operation. In SQL Server 2000 databases, data files hold the data stored in the database. Every SQL Server 2000 database has at least one primary data file, and can optionally have multiple secondary data files to hold data that does not fit on the primary data file.

See also: log file

data integrity

A state in which all the data values stored in the database are correct. If incorrect data values have been stored in a database, the database is said to have lost data integrity.

data lineage

Information used by Data Transformation Services (DTS), in conjunction with Meta Data Services, that records the history of package execution and data transformations for each piece of data.

data manipulation language (DML)

The subset of SQL statements used to retrieve and manipulate data.

data mart

A subset of the contents of a data warehouse. A data mart tends to contain data focused at the department level, or on a specific business area.

See also: data warehouse

data member

A child member generated for a nonleaf member in a parent-child dimension. A data member contains a value directly associated with a nonleaf member that is independent of the summary value calculated from the descendants of the member. For example, a data member can contain a manager's salary so that either individual salaries or summarized salaries can be displayed.

data modification

An operation that adds, deletes, or changes information in a database using Transact-SQL statements such as INSERT, DELETE, and UPDATE.

data pump

An OLE DB service provider that provides the infrastructure to import, export, and transform data between heterogeneous data stores using Data Transformation Services (DTS).

data scrubbing

Part of the process of building a data warehouse out of data coming from multiple online transaction processing (OLTP) systems. The process must address errors such as incorrect spellings, conflicting spelling conventions between two systems, and conflicting data (such as having two part numbers for the same part).

data source

In ADO and OLE DB, the location of a source of data exposed by an OLE DB provider.

See also: ODBC data source

data source

The source of data for an object such as a cube or dimension. It is also the specification of the information necessary to access source data. It sometimes refers to an object of ClassType clsDataSource .

data source name (DSN)

The name assigned to an ODBC data source. Applications can use DSNs to request a connection to a system ODBC data source, which specifies the computer name and (optionally) the database to which the DSN maps.

data type

An attribute that specifies what type of information can be stored in a column, parameter, or variable. System-supplied data types are provided by SQL Server; user-defined data types can also be created.

See also: base data type

data warehouse

A database specifically structured for query and analysis. A data warehouse typically contains data representing the business history of an organization.

See also: fact table, data mart

data-definition query

An SQL query that contains Data Definition Language (DDL) statements. These are statements that allow you to create or alter objects (such as tables, indexes, views, and so on) in the database and to migrate database objects from Microsoft Access.

database

A collection of information, tables, and other objects organized and presented to serve a specific purpose, such as searching, sorting, and recombining data. Databases are stored in files.

database catalog

The part of a database that contains the definition of all the objects in the database, as well as the definition of the database.

See also: system catalog

database diagram

A graphical representation of the objects in a database. A database diagram can be either a whole or a partial picture of the structure of a database; it includes objects for tables, the columns they contain, and the relationship between them.

database file

One of the physical files that make up a database.

database language

The language used for accessing, querying, updating, and managing data in relational database systems. SQL is a widely used database language. The Microsoft SQL Server implementation of SQL is called Transact-SQL.

database object

A database component. A table, index, trigger, view, key, constraint, default, rule, user-defined data type, or stored procedure in a database. May also refer to a database.

database object

An object (tables, fields, and joins) that is used in an English Query application to answer queries.

database owner

A member of the database administrator role of a database. There is only one database owner. The owner has full permissions in that database and determines the access and capabilities provided to other users.

database project

A collection of one or more data connections (a database and the information needed to access that database). When you create a database project, you can connect to one or more databases through ODBC and view their components through a visual user interface that includes a Database Designer for designing and creating databases and a Query Designer for creating SQL statements for any ODBC-compliant database.

database role

A collection of users and groups with the same access to an Analysis Services database. You can assign a database role to multiple cubes in the database, thereby granting the role's users access to these cubes.

See also: cube role, custom rule

database schema

The names of tables, fields, data types, and primary and foreign keys of a database. Also known as the database structure.

database script

A collection of statements used to create database objects. Transact-SQL scripts are saved as files, usually ending with .sql.

dataset

In OLE DB for OLAP, the set of multidimensional data that is the result of executing a Multidimensional Expressions (MDX) SELECT statement. For more information about datasets, see the OLE DB documentation.

datetime data type

A SQL Server system data type that stores a combined date and time value from January 1, 1753, through December 31, 9999, with an accuracy of three-hundredths of a second, or 3.33 milliseconds.

DBCS

See definition for: double-byte character set (DBCS)

DCL

See definition for: Data Control Language (DCL)

DDL

See definition for: data definition language (DDL)

deadlock

A situation when two users, each having a lock on one piece of data, attempt to acquire a lock on the other's piece. Each user would wait indefinitely for the other to release the lock, unless one of the user processes is terminated. SQL Server detects deadlocks and terminates one user's process.

See also: livelock

decimal data type

Fixed precision and scale numeric data from -10^38 -1 through 10^38 -1.

decision support

Systems designed to support the complex analytic analysis required to discover business trends. The information retrieved from these systems allows manager to make business decisions based on timely and accurate analysis of business trends.

decision tree

A treelike model of data produced by certain data mining methods. Decision trees can be used for prediction.

See also: prediction

declarative referential integrity (DRI)

FOREIGN KEY constraints defined as part of a table definition that enforce proper relationships between tables. The constraints ensure that proper actions are taken when DELETE, INSERT, and UPDATE statements remove, add, or modify primary or foreign key values. The DRI actions enforced by FOREIGN KEY constraints can be supplemented with additional referential integrity logic defined in triggers on a table.

default

A data value, option setting, collation, or name assigned automatically by the system if a user does not specify the value, setting, collation, or name. An action taken automatically at certain events if a user has not specified the action to take.

DEFAULT constraint

A property defined for a table column that specifies a constant to be used as the default value for the column. If any subsequent INSERT or UPDATE statement specifies a value of NULL for the column, or does not specify a value for the column, the constant value defined in the DEFAULT constraint is placed in the column.

default database

The database the user is connected to immediately after logging in to SQL Server.

default instance

The copy of SQL Server that uses the computer name on which it is installed as its name.

See also: named instance, multiple instances

default language

The language that SQL Server 2000 uses for errors and messages if a user does not specify a language. Each SQL Server 2000 login has a default language.

default member

The dimension member used in a query when no member is specified for the dimension. The default member of a dimension is the All member if an (All) level exists, or else an arbitrary member of the highest level. You can also set default members for individual roles in custom rules for dimension security.

See also: All member

default result set

The default mode SQL Server uses to return a result set back to a client. Rows are sent to the client in the order they are placed in the result set, and the application must process the rows in this order. After executing an SQL statement on a connection, the application cannot do anything on the connection other than retrieve the rows in the result set until all the rows have been retrieved. The only other action that an application can perform before the end of the result set is to cancel the remainder of the result set. This is the fastest method to get rows from SQL Server to the client.

See also: firehose cursors

Delete query

A query (SQL statement) that removes rows from one or more tables.

delimiter

In Transact-SQL, characters that indicate the start and end of an object name, using either double quotation marks ("") or brackets ([]).

denormalize

To introduce redundancy into a table in order to incorporate data from a related table. The related table can then be eliminated. Denormalization can improve efficiency and performance by reducing complexity in a data warehouse schema.

See also: star schema

density

The percentage of cells that contain data in a multidimensional structure. Analysis Services stores only cells that contain data. A dense cube requires more storage than a sparse cube of identical structure design.

See also: data explosion, sparsity

deny

Removes a permission from a user account and prevents the account from gaining permission through membership in groups or roles within the permission.

dependencies

The views and procedures that depend on the specified table or view.

descendant

A member in a dimension hierarchy that is related to a member of a higher level within the same dimension. For example, in a Time dimension containing the levels Year, Quarter, Month, and Day, January is a descendant of 1997.

See also: ancestor, child, parent, sibling

destination object

An object in a repository that participates in a relationship such that the object is the destination of the relationship. For example, component is the destination object in the relationship project has component .

See also: origin object

device

See definition for: file

dictionary entry

Defined words in the English Query dictionary. You can make additions to the dictionary through the English Query domain editor by specifying the word, its part of speech, and an optional irregular form.

differential database backup

A database backup that records only those changes made to the database since the last full database backup. A differential backup is smaller, and is faster to restore than a full backup and has minimal effect on performance.

dimension

A structural attribute of a cube, which is an organized hierarchy of categories (levels) that describe data in the fact table. These categories typically describe a similar set of members upon which the user wants to base an analysis. For example, a geography dimension might include levels for Country, Region, State or Province, and City.

See also: measure, virtual dimension, level, member group

dimension hierarchy

One of the hierarchies of a dimension.

See also: hierarchy

dimension table

A table in a data warehouse whose entries describe data in a fact table. Dimension tables contain the data from which dimensions are created.

See also: fact table, primary dimension table

direct connect

The state of being connected to a back-end database, so that any changes you make to a database diagram automatically update your database when you save the diagram or selected items in it.

direct object

A noun (along with any of its modifiers) naming whom or what after a transitive verb. For example, the customer buys the products (the products is the direct object.)

direct response mode

The default mode in which SQL Server statistics are gathered separately from the SQL Server Statistics display. Data is available immediately to SQL Server Performance Monitor; however, the statistics displayed are one period behind the statistics retrieved.

dirty pages

Buffer pages that contain modifications that have not been written to disk.

dirty read

Reads that contain uncommitted data. For example, transaction1 changes a row. Transaction2 reads the changed row before transaction1 commits the change. If transaction1 rolls back the change, transaction2 has read a row that never logically existed.

distribute

To move transactions or snapshots of data from the Publisher to Subscribers, where they are applied to the destination tables in the subscription databases.

distributed query

A single query that accesses data from multiple data sources.

distribution database

A database on the Distributor that stores data for replication including transactions, snapshot jobs, synchronization status, and replication history information.

distribution retention period

The distribution retention period determines the amount of information stored for a replication agent and the length of time subscriptions will remain active in the distribution database. When the distribution retention period is exceeded, the Distribution Clean Up Agent runs.

Distributor

A server that hosts the distribution database and stores history data, and/or transactions and meta data.

See also: local Distributor, remote Distributor

DML

See definition for: data manipulation language (DML)

domain

In Windows 2000 security, a collection of computers grouped for viewing and administrative purposes that share a common security database. In relational databases, the set of valid values allowed in a column.

domain integrity

An integrity mechanism that enforces the validity of entries for a given column. The mechanism, such as the CHECK constraint, can restrict the possible data values by data type, format, or range of values allowed.

double-byte character set (DBCS)

A character set that generally uses two bytes to represent a character, allowing more than 256 characters to be represented. DBCSs are typically used in environments that use ideographic writing systems, such as Japanese, Korean, and Chinese.

DRI

See definition for: declarative referential integrity (DRI)

drill down/drill up

A technique for navigating through levels of data ranging from the most summarized (up) to the most detailed (down). For example, when viewing the details of sales data by year, a user can drill down to display sales data by quarter, and further to display data by month.

drill through

To retrieve the detailed data from which the data in a cube cell was summarized.

DSN

See definition for: data source name (DSN)

DSN-less connection

A type of data connection that is created based on information in a data source name (DSN), but is stored as part of a project or application. DSN-less connections are especially useful for Web applications because they enable you to move the application from one server to another without recreating the DSN on the new server.

DTS package

An organized collection of connections, Data Transformation Services (DTS) tasks, DTS transformations, and workflow constraints defined by the DTS object model and assembled either with a DTS tool or programmatically.

DTS package template

A model Data Transformation Services (DTS) package. The template is used to help create and configure a particular type of package.

dump

See definition for: backup

dump file

See definition for: backup file

dynamic cursor

A cursor that can reflect data modifications made to the underlying data while the cursor is open. Updates, deletes, and inserts made by users are reflected in the dynamic cursor.

dynamic filter

Merge replication filters that restrict data based on a system function or user-defined function (for example: SUSER_SNAME()).

dynamic locking

The process used by SQL Server to determine the most cost-effective locks to use at any one time.

dynamic recovery

The process that detects and/or attempts to correct software failure or loss of data integrity within a relational database management system (RDBMS).

dynamic snapshot

A snapshot of a merge publication with dynamic filters that is applied using bulk copy files to improve performance.

dynamic SQL statements

In Embedded SQL for C, an SQL statement built and executed at run time.

E

encrypted trigger

A trigger that is created with an optional encryption parameter that encrypts the definition text and cannot be decrypted. Encryption makes the information indecipherable to protect it from unauthorized viewing or use.

encryption

A method for keeping sensitive information confidential by changing data into an unreadable form.

English Query

Refers to a Microsoft application development product that allows users to ask questions in English, rather than in a computer language such as SQL. For example, you might ask, "How many customers bought products last year?" rather than prepare an equivalent SQL statement.

English Query application

An application based on a relational database that gives end users the ability to pose queries in English, rather than in a computer language such as SQL.

entity

In English Query, an entity is a real-world object, referred to by a noun (person, place, thing, or idea), such as people, products, shipments, cities, and so on. Entities are semantic objects.

entity integrity

A state in which all the rows in a database have a not-null primary key value, all tables have primary keys, and no table has any duplicate primary key values. This ensures that there are no duplicate entries for anything represented in the database.

enumeration

A data type of a property. It specifies that a property value should support a fixed set of constant strings or integer values.

equijoin

A join in which the values in the columns being joined are compared for equality, and all columns are included in the results.

error log

A text file that records system information from SQL Server.

error state number

A number associated with SQL Server 2000 messages that helps Microsoft support engineers find the specific code location that issued the message. This can be helpful in diagnosing errors that may be generated from multiple locations in the SQL Server 2000 code.

escape character

A character used to indicate that another character in an expression is meant literally and not as an operator. For example, in SQL, the character "%" is used as a wildcard character to mean "any number of characters in this position." However, if you want to search for a string such as "10%" (ten percent), you cannot specify "10%" alone as a search string, because the "%" would be interpreted as "any number of characters in addition to 10." By specifying an escape character, you can flag instances where "%" specifically means percent. For example, if you specify the escape character "#", you can indicate a search string of "10#%" to mean "ten percent."

exclusive lock

A lock that prevents any other transaction from acquiring a lock on a resource until the original lock on the resource is released at the end of the transaction. An exclusive lock is always applied during an update operation (INSERT, UPDATE, or DELETE).

explicit transaction

A group of SQL statements enclosed within transaction delimiters. The first delimiter must be either BEGIN TRANSACTION or BEGIN DISTRIBUTED TRANSACTION, and the end delimiter must be one of the following:

COMMIT TRANSACTION

COMMIT WORK

ROLLBACK TRANSACTION

ROLLBACK WORK

SAVE TRANSACTION.

expression

In SQL, a combination of symbols and operators that evaluate to a single data value. Simple expressions can be a constant, variable, column, or scalar function. Complex expressions are one or more simple expressions connected by operators.

extended stored procedure

A function in a dynamic link library (DLL) that is coded using the SQL Server 2000 Extended Stored Procedure API. The function can then be invoked from Transact-SQL using the same statements that are used to execute Transact-SQL stored procedures. Extended stored procedures can be built to perform functionality not possible with Transact-SQL stored procedures.

extent

The unit of space allocated to a SQL Server object, such as a table or index, whenever the object needs more space. In SQL Server 2000, an extent is eight contiguous pages.

F

fact

A row in a fact table in a data warehouse. A fact contains values that define a data event such as a sales transaction.

fact table

A central table in a data warehouse schema that contains numerical measures and keys relating facts to dimension tables. Fact tables contain data that describes specific events within a business, such as bank transactions or product sales.

See also: data warehouse, dimension table, star schema, star join

Federal Information Processing Standard (FIPS)

Standards that apply to computer systems purchased by the American government. Each FIPS standard is defined by the National Institute of Standards and Technology (NIST). The current standard for SQL products is FIPS 127-2, which is based on the ANSI SQL-92 standard. ANSI SQL-92 is aligned with ISO/IEC SQL-92.

fetch

An operation that retrieves a row or block of rows from a cursor. Transact-SQL batches, stored procedures, and triggers use the FETCH statement to fetch from Transact-SQL cursors. Applications use application programming interface (API) fetch functions.

field

An area in a window or record that stores a single data value. Some databases, such as Microsoft Access, use field as a synonym for column.

field length

In bulk copy, the maximum number of characters needed to represent a data item in a bulk copy character format data file.

field terminator

In bulk copy, one or more characters marking the end of a field or row, separating one field or row in the data file from the next.

file

In SQL Server databases, a basic unit of storage for a database. One database can be stored in several files. SQL Server uses three types of files: data files (which store data), log files (which store transaction logs), and backup files (which store backups of a database).

file DSN

Stores connection information for a database in a file that is saved on your computer. The file is a text file with the extension .dsn. The connection information consists of parameters and corresponding values that the ODBC Driver Manager uses to establish a connection.

file storage type

Defines the storage format used in the data file that transfers data from a bulk copy out operation to a bulk copy in operation. In native mode files, all data is stored using the same internal structures that SQL Server 2000 uses to store the data in a database. In character mode files, all data is converted to character strings.

filegroup

In SQL Server, a named collection of one or more files that forms a single unit of allocation or for administration of a database.

fill factor

An attribute of an index that defines the amount of free space on each page of the index. FILLFACTOR accommodates future expansion of table data and reduces the potential for page splits. FILLFACTOR is a value from 1 through 100 that specifies the percentage of the index page to be left empty.

filter

A set of criteria that controls the set of records returned as a result set. Filters can also define the sequence in which rows are returned.

filtering

The ability to restrict data based upon criteria set in the WHERE clause of an SQL statement. For replication, filtering occurs on table articles defined in a publication. The result is partitions of data that can be published to Subscribers.

See also: partitioning, vertical filtering

FIPS

See definition for: Federal Information Processing Standard (FIPS)

firehose cursor

An obsolete term for default result set.

firehose cursors

Obsolete term for default result sets.

See also: default result set

fixed database role

A predefined role that exists in each database. The scope of the role is limited to the database in which it is defined.

fixed server role

A predefined role that exists at the server level. The scope of the role is limited to the SQL Server instance in which it is defined.

FK

See definition for: foreign key (FK)

flattened interface

An interface created to combine members of multiple interfaces.

flattened rowset

A multidimensional data set presented as a two-dimensional rowset in which unique combinations of elements of multiple dimensions are combined on an axis. For more information, see the OLE DB documentation.

float data type

A data type that holds floating-point number data from -1.79E + 308 through 1.79E + 308. float , double precision , and float(n) are SQL Server float data types.

foreign key (FK)

The column or combination of columns whose values match the primary key (PK) or unique key in the same or another table. Also called the referencing key.

foreign table

A table that contains a foreign key.

forward-only cursor

A cursor that cannot be scrolled; rows can be read only in sequence from the first row to the last row.

fragmentation

Occurs when data modifications are made. You can reduce fragmentation and improve read-ahead performance by dropping and re-creating a clustered index.

full outer join

A type of outer join in which all rows in all joined tables are included, whether they are matched or not.

full-text catalog

Stores all of the full-text indexes for tables within a database.

full-text enabling

The process of allowing full-text querying to occur on the current database.

full-text index

The portion of a full-text catalog that stores all of the full-text words and their locations for a given table.

full-text query

As a SELECT statement, a query that searches for words, phrases, or multiple forms of a word or phrase in the character-based columns (of char , varchar , text , ntext , nchar , or nvarchar data types). The SELECT statement returns those rows meeting the search criteria.

full-text service

The SQL Server component that performs the full-text querying.

function

A piece of code that operates as a single logical unit. A function is called by name, accepts optional input parameters, and returns a status and optional output parameters. Many programming languages support functions, including C, Visual Basic, and Transact-SQL. Transact-SQL supplies built-in functions, which cannot be modified, and supports user-defined functions, which can be created and modified by users.

G

global default

A default that is defined for a specific database and is shared by columns of different tables.

global properties

General properties of an English Query application, such as the default year setting or the start date of the fiscal year.

global rule

A rule that is defined for a specific database and is shared by columns of different tables.

global subscriptions

A subscription to a merge publication with an assigned priority value used for conflict detection and resolution.

global variable

In SQL Server, a variable that can be referenced by multiple Data Transformation Services (DTS) tasks. In earlier versions of SQL Server, the term referred to the Transact-SQL system functions whose names start with two at signs (@@).

grant

Applies permissions to a user account, which allows the account to perform an activity or work with data.

granularity

The degree of specificity of information contained in a data element. A fact table that has fine granularity contains many discrete facts, such as individual sales transactions. A table that has coarse granularity stores facts that are summaries of individual elements, such as sales totals per day.

guest

A special user account that is present in all SQL Server 2000 databases and cannot be removed from any database. If a connection is made using a login that has not been assigned a user account in a database and the connection references objects in that database, it has the permissions assigned only to the guest account in that database.

H

heterogeneous data

Data stored in multiple formats. For example, data stored in a SQL Server database, a text file, and an Excel spreadsheet.

hierarchy

A logical tree structure that organizes the members of a dimension such that each member has one parent member and zero or more child members.

See also: level, dimension hierarchy

HOLAP

See definition for: hybrid OLAP (HOLAP)

homogeneous data

Data that comes from multiple data sources that are all managed by the same software (for example, data that comes from several Exchange spreadsheets, or data that comes from several SQL Server 2000 instances). A SQL Server 2000 distributed query is homogeneous if all the data comes from SQL Server 2000 instances.

hop

In data communications, one segment of the path between routers on a geographically dispersed network. A hop is comparable to one "leg" of a journey that includes intervening stops between the starting point and the destination. The distance between each of those stops (routers) would be a communications hop.

horizontal partitioning

To segment a single table into multiple tables based on selected rows. Each of the multiple tables has the same columns but fewer rows.

See also: partitioning

HTML

See definition for: Hypertext Markup Language (HTML)

huge dimension

In Analysis Services, a dimension that contains more than approximately ten million members. Huge dimensions must use relational OLAP (ROLAP) storage mode.

See also: very large dimension

hybrid OLAP (HOLAP)

A storage mode that uses a combination of multidimensional data structures and relational database tables to store multidimensional data. Analysis Services stores aggregations for a HOLAP partition in a multidimensional structure and stores facts in a relational database.

See also: multidimensional OLAP (MOLAP), relational OLAP (ROLAP)

Hypertext Markup Language (HTML)

A system of marking up, or tagging, a document so that it can be published on the World Wide Web. Documents prepared in HTML include reference graphics and formatting tags. You use a Web browser (such as Microsoft Internet Explorer) to view these documents.

I

identifier

The name of an object in a database. An identifier can be from 1 through 128 characters.

identity column

A column in a table that has been assigned the identity property. The identity property generates unique numbers.

identity property

A property that generates values that uniquely identify each row in a table. When inserting rows into a table that has an identity column, SQL Server generates the next identity value automatically based on the last used identity value and the increment value specified during column creation.

idle time

A SQL Server 2000 Agent condition that defines the level of CPU usage by the SQL Server 2000 database engine that constitutes an idle state. SQL Server 2000 Agent jobs can then be created to run whenever the database engine CPU usage falls below the level defined in the idle time definition. This minimizes the impact the SQL Server Agent jobs may have on other tasks accessing the database.

IEC

See definition for: International Electrotechnical Commission (IEC)

image data type

A SQL Server variable-length binary data type with a maximum length of 2^31 - 1 (2,147,483,647) bytes.

immediate updating

An option available with snapshot replication and transactional replication that allows data modifications to be made to replicated data at the Subscriber. The data modifications are then immediately propagated to the Publisher using two-phase commit protocol (2PC).

immediate updating Subscribers

See definition for: immediate updating subscriptions

immediate updating subscriptions

A subscription to a snapshot or transactional publication for which the user is able to make data modifications at the Subscriber. The data modifications are then immediately propagated to the Publisher using two-phase commit protocol (2PC).

implicit transaction

A connection option in which each SQL statement executed by the connection is considered a separate transaction.

implied permission

Permission to perform an activity specific to a role. Implied permissions cannot be granted, revoked, or denied.

incremental update

The set of operations that either adds new members to an existing cube or dimension, or adds new data to a partition. One of three processing options for a cube or partition. One of two processing options for a dimension.

See also: refresh data, process

index

In a relational database, a database object that provides fast access to data in the rows of a table, based on key values. Indexes can also enforce uniqueness on the rows in a table. SQL Server supports clustered and nonclustered indexes. The primary key of a table is automatically indexed. In full-text search, a full-text index stores information about significant words and their location within a given column.

index ORing

An execution strategy that consists of looking up rows of a single table using several indexes, followed by producing the result (by combining the partial results). Usually corresponds to an OR in the WHERE <search_conditions>. For example, WHERE R.a = 6 OR R.b = 7 with indexes on columns R.a and R.b.

index page

A database page containing index rows.

indirect object

A word (or words) naming the one (or ones) indirectly affected by the action of the verb. For example, Emily sliced me some cheese. (Me is the indirect object.)

information model

An object-oriented schema that defines meta data constructs used to specify the structure and behavior of an application, process, component, or software artifact.

initial media

The first medium in each media family.

initial snapshot

Files including schema and data, constraints, extended properties, indexes, triggers and system tables necessary for replication. The initial snapshot is transferred to Subscribers when implementing replication.

See also: synchronization

inner join

An operation that retrieves rows from multiple source tables by comparing the values from columns shared between the source tables. An inner join excludes rows from a source table that have no matching rows in the other source tables.

input member

A member whose value is loaded directly from the data source instead of being calculated from other data.

See also: calculated member

input set

The set of data provided to a Multidimensional Expressions (MDX) value expression upon which the expression operates. For more information about set value expressions, see the OLE DB documentation.

input source

Any table, view, or schema diagram used as an information source for a query.

insensitive cursor

A cursor that does not reflect data modification made to the underlying data by other users while the cursor is open.

Insert query

A query that copies specific columns and rows from one table to another or to the same table.

Insert Values query

A query (SQL statement) that creates a new row and inserts values into specified columns.

instance

A copy of SQL Server running on a computer. A computer can run multiple instances of SQL Server 2000. A computer can run only one instance of SQL Server version 7.0 or earlier, although in some cases it can also be running multiple instances of SQL Server 2000.

int (integer) data type

A SQL Server system data type that holds whole numbers from -2^31 (-2,147,483,648) through 2^31 - 1 (2,147,483,647).

integer

In SQL Server 2000, a data type category that includes the bigint , int , smallint , and tinyint data types.

integrated security

See definition for: Windows Authentication

integrity constraint

A property defined on a table that prevents data modifications that would create invalid data.

intent lock

A lock placed on one level of a resource hierarchy to protect shared or exclusive locks on lower-level resources. For example, before a SQL Server 2000 database engine task applies shared or exclusive row locks within a table, it places an intent lock on the table. If another task tries to apply a shared or exclusive lock at the table level, it is blocked by the table-level intent lock held by the first task. The second task does not have to check for individual page or row locks before locking the table, it only has to check for an intent lock on the table.

interactive structured query language (ISQL)

An interactive command prompt utility provided with SQL Server that allows users to execute Transact-SQL statements or batches from a server or workstation and view the results returned.

interface

A defined set of properties, methods, and collections that form a logical grouping of behaviors and data. Classes are defined by the interfaces that they implement. An interface may be implemented by many different classes.

interface implication

If an interface implies another interface, then any class that implements the first interface must also implement the second interface. Interface implication is used in an information model to get some of the effects of multiple inheritance.

internal identifier

A more compact form of an object identifier in a repository. An internal identifier is guaranteed to be unique only within a single repository.

See also: object identifier

International Electrotechnical Commission (IEC)

One of two international standards bodies responsible for developing international data communications standards. The International Electrotechnical Commission (IEC) works closely with the International Organization for Standardization (ISO) to define standards of computing. They jointly published the ISO/IEC SQL-92 standard for SQL.

International Organization for Standardization (ISO)

One of two international standards bodies responsible for developing international data communications standards. International Organization for Standardization (ISO) works closely with the International Electrotechnical Commission (IEC) to define standards of computing. They jointly published the ISO/IEC SQL-92 standard for SQL.

Internet-enabled

A publication setting that enables replication to Internet Subscribers.

interprocess communication (IPC)

A mechanism through which operating system processes and threads exchange data and messages. IPCs include local mechanisms such as Windows shared memory, or network mechanisms such as Windows Sockets.

IPC

See definition for: interprocess communication (IPC)

irregular form

A form of an English word that is an exception to the standard rules of inflection. For example, the past-tense of run is ran , not runned ; likewise, the plural of alumnus is alumni , not alumnuses .

irregular form type

The type of inflection (plural, past tense, or unknown) for which a word uses an irregular form. For example, the word woman has an irregular plural form (women), as you don't form the plural of woman in the standard way by adding -s or -es.

irregular noun

A noun plural that is not formed by adding -s or -es, such as men or women.

irregular verb

A verb that is not inflected in the usual ways. One example of an irregular verb is one that does not add -ed to the root form to create the past tense and past participle. There are several common types of irregular verbs classified according to how they indicate past tense and past participle: vowel changes (begin, began, begun); -en added (beat, beat, beaten); vowel changes (spin, spun, spun); -d changes to -t (lend, lent, lent); no change (put, put, put).

ISO

See definition for: International Organization for Standardization (ISO)

isolation level

The property of a transaction that controls the degree to which data is isolated for use by one process and guarded against interference from other processes. Setting the isolation level defines the default locking behavior for all SELECT statements in your SQL Server session.

ISQL

See definition for: interactive structured query language (ISQL)

J

job

A specified series of operations, called steps, performed sequentially by SQL Server Agent.

join

As a verb, to combine the contents of two or more tables and produce a result set that incorporates rows and columns from each table. Tables are typically joined using data that they have in common. As a noun, the process or result of joining tables, as in the term "inner join" to indicate a particular method of joining tables.

See also: join column

join column

A column referenced in a join condition.

See also: join

join condition

A comparison clause that specifies how tables are related by their join columns.

join field

See definition for: join column

join filter

A row filter used in merge replication that defines a relationship between two tables that will be enforced during synchronization, which is similar to specifying a join between two tables.

join operator

A comparison operator in a join condition that determines how the two sides of the condition are evaluated and which rows are returned.

join path

A series of joins indicating how two tables are related. For example, Sales.SalesRepIDSalesReps.ID, SalesReps.BranchIDBranches.ID.

join table

See definition for: junction table

junction table

A table that establishes a relationship between other tables. The junction table contains foreign keys referencing the tables that form the relationship. For example, an OrderParts junction table can show what parts shipped with each order by having foreign keys to an Orders table and a Parts table.

K

kernel

In SQL Server 2000, a subset of the storage engine that is referenced in some error messages. In Windows 2000, the core of the operating system that performs basic operations.

key

A column or group of columns that uniquely identifies a row (PRIMARY KEY), defines the relationship between two tables (FOREIGN KEY), or is used to build an index.

See also: key column

key column

A column referenced by a primary, foreign, or index key.

See also: key

key range lock

A lock used to lock ranges between records in a table to prevent phantom insertions or deletions into a set of records. Ensures serializable transactions.

keyset-driven cursor

A cursor that shows the effects of updates made to its member rows by other users while the cursor is open, but does not show the effects of inserts or deletes.

keyword

A reserved word in SQL Server that performs a specific function, such as to define, manipulate, and access database objects.

L

large level

A dimension level that contains a number of members that equals or exceeds the threshold for large levels. This threshold is variable and is set in the Properties dialog box of Analysis Manager.

latency

The amount of time that elapses when a data change is completed at one server and when that change appears at another (for example, the time between when a change is made at a Publisher and when it appears at the Subscriber).

LCID

See definition for: locale identifier (LCID)

leaf

In a tree structure, an element that has no subordinate elements. For example, in Analysis Services, a leaf is a dimension member that has no descendants.

See also: nonleaf

leaf level

The bottom level of a clustered or nonclustered index. In a clustered index, the leaf level contains the actual data pages of the table. In a nonclustered index, the leaf level either points to data pages or points to the clustered index (if one exists), rather than containing the data itself.

leaf member

A dimension member without descendants.

left outer join

A type of outer join in which all rows from the left-most table in the JOIN clause are included. When rows in the left table are not matched by rows in the right table, all result set columns that come from the right table are assigned a value of NULL.

level

The name of a set of members in a dimension hierarchy such that all members of the set are at the same distance from the root of the hierarchy. For example, a time hierarchy may contain the levels Year, Month, and Day.

See also: dimension, hierarchy

level hierarchy

See definition for: dimension hierarchy

library

In Analysis Services, a folder that contains shared objects such as shared dimensions that can be used by multiple objects within a database.

linked cube

A cube based on a cube defined on another Analysis server.

See also: publishing server, source cube, subscribing server

linked server

A definition of an OLE DB data source used by SQL Server 2000 distributed queries. The linked server definition specifies the OLE DB provider required to access the data, and includes enough addressing information for the OLE DB provider to connect to the data. Any rowsets exposed by the OLE DB data source can then be referenced as tables, called linked tables, in SQL Server 2000 distributed queries.

See also: local server

linked table

An OLE DB rowset exposed by an OLE DB data source that has been defined as a linked server for use in SQL Server 2000 distributed queries. The rowsets exposed by the linked server can be referenced as tables in distributed queries.

linking table

A table that has associations with two other tables and is used indirectly as an association between those two tables.

livelock

A request for an exclusive lock that is repeatedly denied because a series of overlapping shared locks keeps interfering. SQL Server detects the situation after four denials and refuses further shared locks. A livelock also occurs when read transactions monopolize a table or page, forcing a write transaction to wait indefinitely.

See also: deadlock

local cube

A cube created and stored with the extension .cub on a local computer using PivotTable Service.

local Distributor

A server that is configured as both a Publisher and a Distributor for SQL Server Replication.

See also: Distributor, remote Distributor

local group

A group in Windows NT 4.0 or Windows 2000 containing user accounts and global groups from the domain group in which they are created and any trusted domain. Local groups cannot contain other local groups.

local login identification

The identification (ID) a user must use to log in to a local server. A login ID can have up to 128 characters. The characters can be alphanumeric; however, the first character must be a letter (for example, CHRIS or TELLER8).

local server

In SQL Server 2000 connections, an instance of SQL Server 2000 running on the same computer as the application.

When resolving references to database objects in a Transact-SQL statement, the instance of SQL Server 2000 executing the statement.

In SQL Server 2000 distributed queries, the instance of SQL Server 2000 executing the distributed query. The local server then accesses any linked servers referenced in the query.

In SQL Server 2000 remote stored procedures, the instance of SQL Server executing an EXEC statement that references a remote stored procedure. The local server then passes the execution request to the remote server on which the remote stored procedure resides.

See also: linked server, remote server

local subscription

A subscription to a merge publication using the priority value of the Publisher for conflict detection and resolution.

local variable

A user-defined variable that has an assigned value. A local variable is defined with a DECLARE statement, assigned an initial value with a SELECT or SET statement, and used within the statement batch or procedure in which it was declared.

locale

The Windows operating-system attribute that defines certain behaviors related to language. The locale defines the code page, or bit patterns, used to store character data, and the order in which characters are sorted. It also defines language-specific items such as the format used for dates and time and the character used to separate decimals in numbers. Each locale is identified by a unique number, called a locale identifier or LCID. SQL Server 2000 collations are similar to locales in that the collations define language-specific types of behaviors for instances of SQL Server 2000.

See also: collation, locale identifier (LCID)

locale identifier (LCID)

A number that identifies a Windows-based locale.

See also: locale

lock

A restriction on access to a resource in a multiuser environment. SQL Server locks users out of a specific row, column, or file automatically to maintain security or prevent concurrent data modification problems.

lock escalation

The process of converting many fine-grain locks into fewer coarse-grain locks, thereby reducing system overhead.

log file

A file or set of files containing a record of the modifications made in a database.

See also: data file

logical name

A name used by SQL Server to identify a file. A logical name for a file must correspond to the rules for identifiers and can have as many as 30 characters (for example, ACCOUNTING or LIBRARY).

logical operators

The operators AND, OR, and NOT. Used to connect search conditions in WHERE clauses.

login (account)

An identifier that gives a user permission to connect to SQL Server 2000 using SQL Server Authentication. Users connecting to SQL Server 2000 using Windows NT Authentication are identified by their Windows 2000 login, and do not need a separate SQL Server 2000 login.

login security mode

A security mode that determines the manner in which a SQL Server 2000 instance validates a login request. There are two types of login security: Windows Authentication and SQL Server authentication.

lookup table

A table, either in a database or hard-coded in the English Query application, that contains codes and the English word or phrase they represent. For example, a gender lookup table contains the following code and English descriptions:

M, Male

M

machine DSN

Stores connection information for a database in the system registry. The connection information consists of parameters and corresponding values that the ODBC Driver Manager uses to establish a connection.

Make Table query

A query (SQL statement) that creates a new table and then creates rows in it by copying rows from an existing table.

many-to-many relationship

A relationship between two tables in which rows in each table have multiple matching rows in the related table. Many-to-many relationships are maintained by using a third table called a junction table and adding the primary key columns from each of the other two tables to this table.

many-to-one relationship

A relationship between two tables in which one row in one table can relate to many rows in another table.

MAPI

See definition for: Messaging Application Programming Interface (MAPI)

master database

The database that controls the operation of each instance of SQL Server. It is installed automatically with each instance of SQL Server and keeps track of user accounts, remote user accounts, and remote servers that each instance can interact with. It also tracks ongoing processes, configurable environment variables, system error messages, tapes and disks available on the system, and active locks.

master definition site

See definition for: Publisher

master file

The file installed with earlier versions of SQL Server used to store the master , model , and tempdb system databases and transaction logs and the pubs sample database and transaction log.

master site

See definition for: Distributor

MDX

See definition for: Multidimensional Expressions (MDX)

measure

In a cube, a set of values that are based on a column in the cube's fact table and are usually numeric. Measures are the central values that are aggregated and analyzed.

See also: dimension

measurement

In English Query, an option in the Adjective Phrasing dialog box. Using it, you can specify some measurement that is represented in an entity. For example, the relationship expressed as the city is some temperature might be represented by an Area entity and a Temperature entity.

media description

The text describing the media set.

See also: media set

media family

All media in a set written by a single device (for example, an initial medium and all continuation media, if any).

See also: media set

media header

Provides information about the backup media.

media name

The descriptive name for the entire backup media set.

media set

All media involved in a backup operation.

See also: media description, media family

member

An item in a dimension representing one or more occurrences of data. A member can be either unique or nonunique. For example, 1997 and 1998 represent unique members in the year level of a time dimension, whereas January represents nonunique members in the month level because there can be more than one January in the time dimension if it contains data for more than one year.

See also: virtual dimension

member delegation

A modeling concept that describes how interface members are mapped from one interface to another.

member group

A system-generated parent of a collection of consecutive dimension members.

See also: dimension

member key column

A dimension level's property that specifies the identifiers of the members of the level. The value of this property can specify a column that contains the identifiers or an expression that evaluates to the identifiers.

See also: member name column, member variable

member name column

A dimension level's property that specifies the names of the members of the level. The value of his property can specify a column that contains the names or an expression that evaluates to the names.

See also: member key column, member variable

member property

Information about the members of a dimension level in addition to that contained in the dimension (for example, the color of a product or the telephone number of a sales representative). For more information about member properties, see the OLE DB documentation.

See also: virtual dimension

member variable

The value used internally by Analysis Services to identify a dimension member. The MemberKeyColumn property specifies the member variables for a dimension. For example, a number from 1 through 12 could be the member variable that corresponds to a month of the year.

See also: member key column, member name column

memo

A type of column containing long strings of text, typically more than 255 characters. This is the Access equivalent of a SQL Server text data type.

merge

The operation that combines two partitions into a single partition.

merge replication

A type of replication that allows sites to make autonomous changes to replicated data, and at a later time, merge changes and resolve conflicts when necessary.

See also: snapshot replication, transactional replication

message number

A number that identifies a SQL Server 2000 error message.

Messaging Application Programming Interface (MAPI)

An e-mail application programming interface (API).

meta data

Information about the properties of data, such as the type of data in a column (numeric, text, and so on) or the length of a column. It can also be information about the structure of data or information that specifies the design of objects such as cubes or dimensions.

method

A function that performs an action by using a COM object, as in SQL-DMO, OLE DB, and ActiveX Data Objects (ADO).

See also: Component Object Model (COM)

mining model

An object that contains the definition of a data mining process and the results of the training activity. For example, a data mining model may specify the input, output, algorithm, and other properties of the process and hold the information gathered during the training activity, such as a decision tree.

mining model training

The process a data mining model uses to estimate model parameters by evaluating a set of known and predictable data. Also, the act of causing a mining model to evaluate training data.

See also: training data set

mirroring

The process for protecting against the loss of data due to disk failure by maintaining a fully redundant copy of data on a separate disk. Mirroring can be implemented at several levels: in SQL Server 2000, in the operating system, and in the disk controller hardware.

Mixed Mode

Combines Windows Authentication and SQL Server Authentication. Mixed Mode allows users to connect to an instance of SQL Server, through either a Windows NT 4.0 or Windows 2000 user account or a SQL Server login.

model

In English Query, a model is the collection of all information that is known about the objects in the English Query application. This information includes: the specified database objects (such as tables, fields, and joins); semantic objects (such as entities, the relationships between them, additional dictionary entries); and global domain default options.

model database

A database installed with SQL Server that provides the template for new user databases. SQL Server 2000 creates a new database by copying in the contents of the model database and then expanding it to the size requested.

model dependency

A relationship between two or more models in which one model is dependent on the information of another model.

module

A group of objects in a project. You can move objects between modules in a project, thus organizing those objects for a dispersed development environment.

modulo

An arithmetic operator that provides the integer remainder after a division involving two integers.

MOLAP

See definition for: multidimensional OLAP (MOLAP)

money data type

A SQL Server system data type that stores monetary values from -2^63 (-922,337,203,685,477.5808) through 2^63 - 1 (+922,337,203,685,477.5807), with accuracy to a ten-thousandth of a monetary unit.

Multidimensional Expressions (MDX)

A syntax used for defining multidimensional objects and querying and manipulating multidimensional data.

multidimensional OLAP (MOLAP)

A storage mode that uses a proprietary multidimensional structure to store a partition's facts and aggregations or a dimension. The data of a partition is completely contained within the multidimensional structure.

See also: relational OLAP (ROLAP), hybrid OLAP (HOLAP)

multidimensional structure

A database paradigm that treats data not as relational tables and columns, but as information cubes that contain dimension and summary data in cells. Each cell is addressed by a set of coordinates that specify a position in the structure's dimensions. For example, the cell at coordinates {SALES, 1997, WASHINGTON, SOFTWARE} would contain the summary of software sales in Washington in 1997.

See also: cube

multiple inheritance

A modeling term that describes how an interface receives the characteristics of more than one parent interface.

multiple instances

Multiple copies of SQL Server running on the same computer. There can be one default instance, which can be any version of SQL Server. There can be multiple named instances of SQL Server 2000.

See also: default instance, named instance

multithreaded server application

An application that creates multiple threads within a single process to service multiple user requests at the same time.

multiuser

The ability of a computer to support many users operating at the same time, while providing the computer system's full range of capabilities to each user.

N

name phrasing

An English description of a relationship in which one entity is the name of another entity. For example, in the sentence "Custnames are the names of Customers", Custnames and Customers are both entities.

named instance

An installation of SQL Server 2000 that is given a name to differentiate it from other named instances and from the default instance on the same computer. A named instance is identified by the computer name and instance name.

See also: default instance, multiple instances

named pipe

An interprocess communication (IPC) mechanism that SQL Server uses to provide communication between clients and servers. Named pipes permit access to shared network resources.

named set

A set of dimension members or a set expression that is created for reuse, for example, in Multidimensional Expressions (MDX) queries.

naming relationship

A naming convention that identifies the destination objects of that relationship by name.

native format

Bulk copy data files in which the data is stored using the same internal data structures SQL Server uses to store data in SQL Server databases. Bulk copy can quickly process native mode files because it does not have to convert data when transferring it between SQL Server and the bulk copy data file.

See also: character format

nchar data type

A fixed-length Unicode data type with a maximum of 4,000 characters. Unicode characters use 2 bytes per character and support all international characters.

nested query

A SELECT statement that contains one or more subqueries, or another term for subquery.

nested table

A data mining model configuration in which a column of a table contains a table.

Net-Library

A SQL Server communications component that isolates the SQL Server client software and database engine from the network APIs. The SQL Server client software and database engine send generic network requests to a Net-Library, which translates the request to the specific network commands of the protocol chosen by the user.

nickname

When used with merge replication system tables, a name for another Subscriber that is known to already have a specified generation of updated data. Used to avoid sending an update to a Subscriber that has already received those changes.

niladic functions

Functions that do not have any input parameters. Most niladic SQL Server functions return system information.

noise word

Words that do not participate in a full-text query search. For example, a, and, the, and so on.

nonclustered index

An index in which the logical order of the index is different than the physical, stored order of the rows on disk.

nonleaf

In a tree structure, an element that has one or more subordinate elements. For example, in Analysis Services, a dimension member that has one or more descendants. In SQL Server indexes, an intermediate index node that points to other intermediate nodes or leaf nodes.

See also: leaf

nonleaf member

A member with one or more descendants.

nonrepeatable read

When a transaction reads the same row more than one time, and between the two (or more) reads, a separate transaction modifies that row. Because the row was modified between reads within the same transaction, each read produces different values, which introduces inconsistency.

normalization rules

A set of database design rules that minimizes data redundancy and results in a database in which the database engine and application software can easily enforce integrity.

noun

A part of speech that names a person, place, thing, idea, animal, quality, or action. A noun usually changes form to indicate the plural and the possessive case.

ntext data type

A variable-length Unicode data type that can hold a maximum of 2^30 - 1 (1,073,741,823) characters. ntext columns store a 16-byte pointer in the data row, and the data is stored separately.

NULL

An entry that has no explicitly assigned value. NULL is not equivalent to zero or blank. A value of NULL is not considered to be greater than, less than, or equivalent to any other value, including another value of NULL.

nullability

The attribute of a column, parameter, or variable that specifies whether it allows null data values.

numeric expression

Any expression that evaluates to a number. The expression can be any combination of variables, constants, functions, and operators.

nvarchar data type

A variable-length Unicode data type with a maximum of 4,000 characters. Unicode characters use 2 bytes per character and support all international characters. sysname is a system-supplied user-defined data type that is a synonym for nvarchar(128) and is used to reference database object names.

O

object

In databases, one of the components of a database: a table, index, trigger, view, key, constraint, default, rule, user-defined data type, or stored procedure.

object dependencies

References to other objects when the behavior of the first object can be affected by changes in the object it references. For example, if a stored procedure references a table, changes to the table can affect the behavior of the stored procedure.

object identifier

A unique name given to an object.

In Meta Data Services, a unique identifier constructed from a globally unique identifier (GUID) and an internal identifier. All objects must have an object identifier.

See also: internal identifier

object owner

The security account that controls the permissions for an object, usually the creator of the object. Object owner is also called the database object owner.

object permission

An attribute that controls the ability to perform operations on an object. For example, table or view permissions control which users can execute SELECT, INSERT, UPDATE, and DELETE statements against the table or view.

object variable

A variable that contains a reference to an object.

ODBC

See definition for: Open Database Connectivity (ODBC)

ODBC data source

The location of a set of data that can be accessed using an ODBC driver. Also, a stored definition that contains all of the connection information an ODBC application requires to connect to the data source.

See also: data source

ODBC driver

A dynamic-link library (DLL) that an ODBC-enabled application, such as Excel, can use to access an ODBC data source. Each ODBC driver is specific to a database management system (DBMS), such as SQL Server, Access, and so on.

ODS

See definition for: Open Data Services (ODS)

OIM

See definition for: Open Information Model (OIM)

OLAP

See definition for: online analytical processing (OLAP)

OLE Automation controller

A programming environment (for example, Visual Basic) that can drive Automation objects.

OLE Automation objects

A Component Object Model (COM) object that provides Automation-compatible interfaces.

OLE Automation server

An application that exposes programmable automation objects to other applications, which are called "automation clients." Exposing programmable objects enables clients to "automate" certain functions by directly accessing those objects and using the services they make available. For example, a word processor might expose its spell-checking functionality so that other programs can use it.

OLE DB

A COM-based application programming interface (API) for accessing data. OLE DB supports accessing data stored in any format (databases, spreadsheets, text files, and so on) for which an OLE DB provider is available.

See also: OLE DB for OLAP

OLE DB consumer

Any software that calls and uses the OLE DB application programming interface (API).

OLE DB for OLAP

Formerly, the separate specification that addressed OLAP extensions to OLE DB. Beginning with OLE DB 2.0, OLAP extensions are incorporated into the OLE DB specification.

See also: OLE DB

OLE DB provider

A software component that exposes OLE DB interfaces. Each OLE DB provider exposes data from a particular type of data source (for example SQL Server databases, Access databases, or Excel spreadsheets).

OLTP

See definition for: online transaction processing (OLTP)

one-to-many relationship

In relational databases, a relationship between two tables in which a single row in the first table can be related to one or more rows in the second table, but a row in the second table can be related only to one row in the first table.

one-to-one relationship

In relational database, a relationship between two tables in which a single row in the first table can be related only to one row in the second table, and a row in the second table can be related only to one row in the first table.

online analytical processing (OLAP)

A technology that uses multidimensional structures to provide rapid access to data for analysis. The source data for OLAP is commonly stored in data warehouses in a relational database.

online redo log

See definition for: transaction log

online transaction processing (OLTP)

A data processing system designed to record all of the business transactions of an organization as they occur. An OLTP system is characterized by many concurrent users actively adding and modifying data.

Open Data Services (ODS)

The layer of the SQL Server database engine that transfers client requests to the appropriate functions in the database engine. Open Data Services exposes the extended stored procedure API used to write DLL functions that can be called from Transact-SQL statements.

Open Database Connectivity (ODBC)

A data access application programming interface (API) that supports access to any data source for which an ODBC driver is available. ODBC is aligned with the American National Standards Institute (ANSI) and International Organization for Standardization (ISO) standards for a database Call Level Interface (CLI).

Open Information Model (OIM)

An information model published by the Meta Data Coalition (MDC) and widely supported by software vendors. The OIM is a formal description of meta data constructs organized by subject area.

optimize synchronization

An option in merge replication that allows you to minimize network traffic when determining whether recent changes have caused a row to move into or out of a partition that is published to a Subscriber.

optimizer

See definition for: query optimizer

ordered set

A set of members returned in a specific order. The ORDER function in a Multidimensional Expressions (MDX) query returns an ordered set.

origin object

An object in a repository that is the origin in a directional relationship. For example, project is the origin object in the relationship project has component .

See also: destination object, sequenced relationship

outer join

A join that includes all the rows from the joined tables that have met the search conditions, even rows from one table for which there is no matching row in the other join table. For result set rows returned when a row in one table is not matched by a row from the other table, a value of NULL is supplied for all result set columns that are resolved to the table that had the missing row.

overfitting

The characteristic of some data mining algorithms that assigns importance to random variations in data by viewing them as important patterns.

P

page

In a virtual storage system, a fixed-length block of contiguous virtual addresses copied as a unit from memory to disk and back during paging operations. SQL Server allocates database space in pages. In SQL Server, a page is 8 kilobytes (KB) in size.

page split

The process of moving half the rows or entries in a full data or index page to two new pages to make room for a new row or index entry.

parent

A member in the next higher level in a hierarchy that is directly related to the current member. The parent value is usually a consolidation of the values of all of its children. For example, in a Time dimension containing the levels Quarter, Month, and Day, Qtr1 is the parent of January.

See also: ancestor, child, descendant, sibling

partition

In Analysis Services, one of the storage containers for data and aggregations of a cube. Every cube contains one or more partitions. For a cube with multiple partitions, each partition can be stored separately in a different physical location. Each partition can be based on a different data source. Partitions are not visible to users; the cube appears to be a single object.

partitioning

The process of replacing a table with multiple smaller tables. Each smaller table has the same format as the original table, but with a subset of the data. Each partitioned table has rows allocated to it based on some characteristic of the data, such as specific key ranges. The rules that define into which table the rows go must be unambiguous. For example, a table is partitioned into two tables. All rows with primary key values lower than a specified value are allocated to one table, and all keys equal to or greater than the value are allocated to the other. Partitioning can improve application processing speeds and reduce the potential for conflicts in multisite update replication. You can improve the usability of partitioned tables by creating a view. The view, created by a union of select operations on all the partitioned tables, presents the data as if it all resided in a single table.

See also: filtering, vertical partitioning, horizontal partitioning

parts of speech

The classes into which words may be grouped according to their form changes and their grammatical relationships. The traditional parts of speech are verbs, nouns, pronouns, adjectives, adverbs, prepositions, conjunctions, and interjections.

pass order

The order of evaluation (from highest to lowest calculation pass number) and calculation (from lowest to highest calculation pass number) for calculated members, custom members, custom rollup formulas, and calculated cells in a multidimensional cube. Pass order is used to determine formula precedence when calculating values for cells in multidimensional cubes, across all calculation passes.

See also: solve order

pass-through query

A query passed uninterpreted to an external server for evaluation. The result set returned by a pass-through query can be used in the FROM clause of a query like an ordinary base table.

pass-through statement

A SELECT statement that is passed directly to the source database without modification or delay. In PivotTable Service, the PASSTHROUGH option is part of the INSERT INTO statement.

passive voice

Indicates that the subject of the verb receives the action of the verb. For example, in the sentence "The customers are sold products", the subject customers receives the action of the verb are sold .

See also: active voice

persistence

The saving of an object definition so it will be available after the current session ends.

phantom

By one task, the insertion of a new row or the deletion of an existing row in a range of rows previously read by another task that has not yet committed its transaction. The task with the uncommitted transaction cannot repeat its original read because of the change to the number of rows in the range. If a connection sets its transaction isolation level to serializable, SQL Server uses key-range locking to prevent phantoms.

phrase

A sequence of grammatically related words lacking a subject or a predicate, or both.

phrasing

A way to express a relationship in English. Types of phrasings include name, adjective, subset, preposition, verb, and trait phrasings. For example, department names are names of departments is an example of name phrasing.

physical name

The path where a file or mirrored file is located. The default is the path of the Master.dat file followed by the first eight characters of the file's logical name. For example, if Accounting is the logical name, and the Master.dat file is located in Sql\Data, the default physical name is Sql\Data\Accounti.dat. For a mirrored file, the default is the path of the Master.mir file followed by the first eight characters of the mirror file's logical name. For example, if Maccount is the name of the mirrored file, and the Master.mir file is located in Sql\Data, the default physical name is Sql\Data\Maccount.mir.

physical reads

A request for a database page in which SQL Server must transfer the requested page from disk to the SQL Server buffer pool. All attempts to read pages are called logical reads. If the page is already in the buffer, there is no associated physical read generated by the logical read. The number of physical reads never exceeds the number of logical reads. In a well-tuned instance of SQL Server, the number of logical reads is typically much higher than the number of physical reads.

pivot

To rotate rows to columns, and columns to rows, in a crosstabular data browser.

To choose dimensions from the set of available dimensions in a multidimensional data structure for display in the rows and columns of a crosstabular structure.

PK

See definition for: primary key (PK)

position

The current location of processing in a cursor. For example, after an application fetches the first 10 rows from a cursor, it is positioned on the tenth row of the cursor. Database APIs also have functions, such as the ODBC SQLSetPos function, that allow an application to move directly to a specific position in a cursor without performing a fetch.

positioned update

An update, insert, or delete operation performed on a row at the current position of the cursor. The actual change is made in the rows of the base tables used to build the current row in the cursor. Transact-SQL batches, stored procedures, and triggers use the WHERE CURRENT OF clause to perform positioned updates. Applications use API functions, such as the ODBC SQLSetPos function, to perform positioned updates.

possessive case

A grammatical case that denotes ownership or a relation analogous to ownership, for example, Mary's blood type, or John's movie.

precision

The maximum total number of decimal digits that can be stored, both to the left and right of the decimal point.

predicate

A basic grammatical division of a sentence that consists of what is said about the subject. For example, in the sentence "The voters elected the incumbent", the subject is voters and the predicate is elected the incumbent .

prediction

A data mining technique that analyzes existing data and uses the results to predict values of attributes for new records or missing attributes in existing records. For example, existing credit application data can be used to predict the credit risk for a new application.

See also: decision tree

prefix characters

A set of 1 to 4 bytes that prefix each data field in a native-format bulk-copy data file. The prefix characters record the length of the data value in the field, or contain -1 when the value is NULL.

prefix length

The number of prefix characters preceding each noncharacter field in a bcp native format data file.

prefix search

Full-text query searching for those columns where the specified character-based text, word, or phrase, is the prefix. When using a phrase, each word within the phrase is considered to be a prefix. For example, a prefix search specifying the phrase "sport fish*" matches "sport fishing", "sportsman fishing supplies", and so on.

preposition

A part of speech that links and relates a noun or noun substitute to another word in the sentence. For example, in the sentence "the dancers leaped across the stage", across is the preposition. Words commonly used as prepositions include about , after , among , before , between , but , during , for , from , in , into , near , of , on , over , to , until , with , and so on.

preposition phrasing

A way of expressing a relationship in English in which an entity serves as a subject and an entity serves as an object and are linked by a preposition. For example, in the sentence, "stories are about subjects", stories is the subject entity, about is the preposition, and subjects is the object.

primary dimension table

In a snowflake schema in a data warehouse, a dimension table that is directly related to and usually joined to the fact table. Additional tables that complete the dimension definition are joined to the primary dimension table instead of to the fact table.

See also: dimension table, snowflake schema

primary key (PK)

A column or set of columns that uniquely identify all the rows in a table. Primary keys do not allow null values. No two rows can have the same primary key value; therefore, a primary key value always uniquely identifies a single row. More than one key can uniquely identify rows in a table, each of these keys is called a candidate key. Only one candidate can be chosen as the primary key of a table; all other candidate keys are known as alternate keys. Although tables are not required to have primary keys, it is good practice to define them. In a normalized table, all of the data values in each row are fully dependent on the primary key. For example, in a normalized employee table that has EmployeeID as the primary key, all of the columns should contain data related to a specific employee. This table does not have the column DepartmentName because the name of the department is dependent on a department ID, not on an employee ID.

primary table

The "one" side of two related tables in a one-to-many relationship. A primary table should have a primary key and each record should be unique. An example of a primary table is a table of customer names that are uniquely identified by a CustomerID primary key field.

private dimension

A dimension created for and used by a specific cube. Unlike shared dimensions, private dimensions are available only to the cube in which they are created.

See also: shared dimension

procedure cache

The part of the SQL Server memory pool that is used to store execution plans for Transact-SQL batches, stored procedures, and triggers. Execution plans record the steps that SQL Server must take to produce the results specified by the Transact-SQL statements contained in the batches, stored procedures, or triggers.

process

In a cube, the series of operations that rebuilds the cube's structure, loads data into a multidimensional structure, calculates summaries, and saves the precalculated aggregations. As a verb, to populate a cube with data and aggregations. It is one of three processing options for a cube.

In a dimension, the operation that loads data from a dimension table in a data warehouse into the levels defined for a dimension and rebuilds the structure of the dimension. It is one of two processing options for a dimension.

In a data mining model, the operation that retrieves training data from a relational or OLAP data source into the structure defined for a data mining model, statistically analyzes it with a data mining algorithm, and saves the statistical data as data mining content. As a verb, to populate a data mining model with data mining content.

See also: incremental update, refresh data

producer

Collects events in a specific event category and sends the data to a SQL Server Profiler queue.

project

In English Query, a file that contains the structure of the relational database and definitions of semantic objects, such as entities, relationships, and dictionary entries. Its extension is *.eqp. It is used to test how English Query translates English questions into SQL statements. Later, it can be compiled into a deployable application file with an *.eqd extension.

pronoun

A part of speech that takes the position of a noun and functions as one, for example, she, he, and we.

proper noun

A noun that is capitalized; a specific name, for example, John Smith.

property

A named attribute of a control, field, or database object that you set to define one of the object's characteristics (such as size, color, or screen location) or an aspect of its behavior (such as whether it is hidden).

property pages

A tabbed dialog box where you can identify the characteristics of tables, relationships, indexes, constraints, and keys. Every object in a database diagram has a set of properties that determine the definition of a database object. Each set of tabs shows only the properties specific to the selected object. If multiple objects are selected, the property pages show the properties of the first object you selected.

provider

An OLE DB provider.

An in-process dynamic link library (DLL) that provides access to a database.

proximity search

Full-text query searching for those occurrences where the specified words are close to one another.

publication

A publication is a collection of one or more articles from one database. This grouping of multiple articles makes it easier to specify a logically related set of data and database objects that you want to replicate at the same time.

publication database

A database on the Publisher from which data and database objects are marked for replication as part of a publication that is propagated to Subscribers.

publication retention period

A predetermined length of time that regulates how long subscriptions will receive updates during synchronizations and remain activated in databases.

published data

Data at the Publisher that has been replicated.

Publisher

A server that makes data available for replication to other servers, detects changed data, and maintains information about all publications at the site.

publishing server

An Analysis server that stores the source cube for one or more linked cubes.

See also: linked cube, subscribing server

publishing table

The table at the Publisher in which data has been marked for replication and is part of a publication.

pubs database

A sample database provided with SQL Server.

pull subscription

A subscription created and administered at the Subscriber. Information about the publication and the Subscriber is stored.

See also: push subscription

push subscription

A subscription created and administered at the Publisher. Information about the publication and Subscriber is stored.

See also: pull subscription

Q

query optimizer

The SQL Server database engine component responsible for generating efficient execution plans for SQL statements.

question

In English Query, an English form of a query, for example, "How many customers bought products last year?" Questions may also be posed as statements to an English Query application, for example, "List the customers that bought products last year."

Question Builder

A tool that supports users' needs to know more about the domain objects so that they can construct questions. They can find out what the domain objects contain, what kind of basic relationships are represented in the domain, and what English phrases can be used to ask about the relationships.

question file (.eqq)

An ASCII text file that contains questions (one to a line) that are ready for testing with the English Query engine. Question files are denoted with the .eqq extension. Questions can be submitted to the question file automatically with the test tool, or a developer can create a list of questions.

question template

A structure that describes a set of questions that can be asked using a particular relationship or set of relationships.

queue

A SQL Server Profiler queue provides a temporary holding place for server events to be captured.

R

ragged hierarchy

A dimension hierarchy in which one or more levels do not contain members in one or more branches of the hierarchy. For example, the state or province level in a geography hierarchy contains no members for countries that do not have states or provinces.

See also: unbalanced hierarchy

range query

A query that specifies a range of values as part of the search criteria, such as all rows from 10 through 100.

rank

For full-text and SQL Server Books Online searches, a value indicating how closely rows or topics match the specified search criteria. For Meta Data Services and Analysis Services, a value indicating the relative positions of elements such as dimension members, hierarchy levels, or tuples in a set.

RDBMS

See definition for: relational database management system (RDBMS)

real data type

A SQL Server system data type that has 7-digit precision. Floating precision number data from -3.40E + 38 through 3.40E + 38. Storage size is 4 bytes.

record

A group of related fields (columns) of information treated as a unit. A record is more commonly called a row in an SQL database.

recordset

The ActiveX Database Objects (ADO) object used to contain a result set. It also exhibits cursor behavior depending on the recordset properties set by an application. ADO recordsets are mapped to OLE DB rowsets.

recovery interval

The maximum amount of time that the database engine should require to recover a database. The database engine ensures that the active portion of the database log is small enough to recover the database in the amount of time specified for the recovery interval.

recursive partitioning

The iterative process, used by data mining algorithm providers, of dividing data into groups until no more useful groups can be found.

redo log file

See definition for: backup file

referenced key

A primary key or unique key referenced by a foreign key.

referencing key

See definition for: foreign key (FK)

referential integrity (RI)

A state in which all foreign key values in a database are valid. For a foreign key to be valid, it must contain either the value NULL, or an existing key value from the primary or unique key columns referenced by the foreign key.

reflexive relationship

A relationship from a column or combination of columns in a table to other columns in that same table. A reflexive relationship is used to compare rows within the same table. In queries, this is called a self-join.

refresh data

The series of operations that clears data from a cube, loads the cube with new data from the data warehouse, and calculates aggregations. Refresh data is used when a cube's underlying data in the data warehouse changes but the cube's structure and aggregation definitions remain the same. One of three processing options for a cube.

See also: incremental update, process

regular cube

A cube that is based on tables and has its own aggregations.

regular dimension

A dimension that is neither a parent-child dimension nor a virtual dimension.

relational database

A collection of information organized in tables. Each table models a class of objects of interest to the organization (for example, Customers , Parts , Suppliers ). Each column in a table models an attribute of the object (for example, LastName , Price , Color ). Each row in a table represents one entity in the class of objects modeled by the table (for example, the customer name John Smith or the part number 1346). Queries can use data from one table to find related data in other tables.

relational database management system (RDBMS)

A system that organizes data into related rows and columns. SQL Server is a relational database management system (RDBMS).

relational OLAP (ROLAP)

A storage mode that uses tables in a relational database to store multidimensional structures.

See also: multidimensional OLAP (MOLAP), hybrid OLAP (HOLAP)

relationship

A link between tables that references the primary key in one table to a foreign key in another table. The relationship line is represented in a database diagram by a solid line if referential integrity between the tables is enforced, or a dashed line if referential integrity is not enforced for INSERT and UPDATE transactions. The endpoints of a relationship line show a primary key symbol to denote a primary key-to-foreign key relationship, or they show an infinity symbol to denote the foreign key side of a one-to-many relationship.

In English Query, an association between entities that describes what those entities have to do with one another. Relationships can be described concisely in English as simple statements about entities (for example, customers purchase products ). More than one join may be required to represent a single relationship.

relationship

In Meta Data Services, a relationship is an association between a pair of objects, where one object is an origin and the other object is a destination. The association repeats for each subsequent pair of objects, so that the destination of one relationship becomes the origin in the next relationship. In this way, all objects in an information model are associated through a chain of relationships that extend from one object to the next throughout the information model.

relationship object

An object representing a pair of objects that assume a role in relation to each other.

See also: sequenced relationship

relationship type

A definition of a relationship between two interfaces, as defined in an information model. A relationship type is similar to a class in that it describes characteristics to which specific instances must conform.

remote data

Data stored in an OLE DB data source that is separate from the current instance of SQL Server. The data is accessed by establishing a linked server definition or using an ad-hoc connector name.

remote Distributor

A server configured as a Distributor that is separate from the server configured as the Publisher.

See also: Distributor, local Distributor

remote login identification

The login identification (login ID) assigned to a user for accessing remote procedures on a remote server.

remote partition

A partition whose data is stored on an Analysis server other than the one used to store the meta data of the partition.

remote server

A definition of an instance of SQL Server used by remote stored procedure calls. Remote servers are still supported in SQL Server 2000, but linked servers offer greater functionality.

See also: local server

remote stored procedure

A stored procedure located on one instance of SQL Server that is executed by a statement on another instance of SQL Server. In SQL Server 2000, remote stored procedures are supported, but distributed queries offer greater functionality.

remote table

A table stored in an OLE DB data source that is separate from the current instance of SQL Server. The table is accessed by either establishing a linked server definition or using an ad-hoc connector name.

replicated data

Data at the Subscriber that has been received from a Publisher.

replication

A process that copies and distributes data and database objects from one database to another and then synchronizes information between databases for consistency.

Replication Conflict Viewer

Allows users to view and resolve conflicts that occurred during the merge replication process and to review the manner in which conflicts have been resolved.

Replication Monitor

Allows users to view and manage replication agents responsible for various replication tasks and to troubleshoot potential problems at the Distributor.

replication scripting

The generation of .sql scripts that can be used to configure and disable replication.

replication topology

Defines the relationship between servers and the copies of data and clarifies the logic that determines how data flows between servers.

repository

The storage container for the meta data used by Analysis Services. Meta data is stored in tables in a relational database and is used to define the parameters and properties of Analysis server objects.

repository

A database containing information models that, in conjunction with the executable software, manage the database. The term can also refer to an installation of Meta Data Services.

repository engine

Object-oriented software that provides management support for and customer access to a repository database.

repository object

A COM object that represents a data construct stored in a repository type library.

Repository SQL schema

A set of standard tables used by the repository engine to manage all repository objects, relationships, and collections. Repository SQL schema maps information model elements to SQL schema elements.

Repository Type Information Model (RTIM)

A core object model that represents repository type definitions for Meta Data Services. This object model is composed of abstract classes upon which instances of information models are based.

republish

When a Subscriber publishes data received from a Publisher to another Subscriber.

republisher

A Subscriber that publishes data that it has received from a Publisher.

resolution strategy

A set of criteria that the repository engine evaluates sequentially when selecting an object, where multiple versions exist and version information is unspecified in the calling program.

restatement

An English query, returned by the English Query engine, that is a check on the query entered by the end user. Restatements give end users a check that the English Query engine interpreted their question correctly. If the restatement is accurate, the correct SQL statements will be generated, and thus the returned answer will be valid.

result

In English Query, an English answer to a question that has been posed to an English Query application.

result set

The set of rows returned from a SELECT statement. The format of the rows in the result set is defined by the column-list of the SELECT statement.

return parameters

A legacy term for stored procedure output parameters, used in the Open Data Services and DB-Library APIs.

reusable bookmark

A bookmark that can be consumed from a rowset for a given table and used on a different rowset of the same table to position on a corresponding row.

revoke

Removes a previously granted or denied permission from a user account, role, or group in the current database.

RI

See definition for: referential integrity (RI)

right outer join

A type of outer join in which all rows in the right-most table in the JOIN clause are included. When rows in the right table are not matched in the left table, all result set columns that come from the left table are assigned a value of NULL.

ROLAP

See definition for: relational OLAP (ROLAP)

role

A SQL Server security account that is a collection of other security accounts that can be treated as a single unit when managing permissions. A role can contain SQL Server logins, other roles, and Windows logins or groups.

role

In Analysis Services, a role uses Windows security accounts to limit scope of access and permissions when users access databases, cubes, dimensions, and data mining models.

See also: rule

roll back

To remove the updates performed by one or more partially completed transactions. Rollbacks are required to restore the integrity of a database after an application, database, or system failure.

See also: commit

roll forward

To apply all the completed transactions from a database or log backup in order to recover a database to a point in time or the point of failure (for example, after events such as the loss of a disk).

root form

The simplest form of a word. For example, the root form of generating is generate. For other verbs, the present, infinitive form should be used when defining dictionary entries in English Query (use run, not ran or runs). For nouns, use the singular, not the plural form as the base word (animal, not animals).

row

In an SQL table, the collection of elements that form a horizontal line in the table. Each row in the table represents a single occurrence of the object modeled by the table and stores the values for all the attributes of that object. For example, in the Northwind sample database, the Employees table models the employees of the Northwind Traders Company. The first row in the table records all the information (for example, name and title) about the employee who has employee ID 1.

See also: column

row aggregate function

A function, which generates summary values that appear as additional rows in the query results (unlike aggregate function results that appear as new columns). It allows you to see detail and summary rows in one set of results. Row aggregate functions (SUM, AVG, MIN, MAX, and COUNT) are used in a SELECT statement with the COMPUTE clause.

row filter

Specifies a subset of rows from a table to be published and when specific rows need to be propagated to Subscribers.

row lock

A lock on a single row in a table.

rowset

The OLE DB object used to contain a result set. It also exhibits cursor behavior depending on the rowset properties set by an application.

RTIM

See definition for: Repository Type Information Model (RTIM)

rule

A database object that is bound to columns or user-defined data types, and specifies which data values are acceptable in a column. CHECK constraints provide the same functionality and are preferred because they are in the SQL-92 standard.

rule

In Analysis Services, a rule specifies restrictions such as Unrestricted, Fully Restricted, or Custom for security read and read/write role permissions.

See also: role

S

sample data

Artificially generated data presented instead of actual data when a cube is queried before it has been processed. Sample data enables you to view the effects of structure changes while modifying a cube.

savepoint

A marker that allows an application to roll back part of a transaction if a minor error is encountered. The application must still commit or roll back the full transaction when it is complete.

scalar aggregate

An aggregate function, such as MIN(), MAX(), or AVG(), that is specified in a SELECT statement column list that contains only aggregate functions. When the column list contains only aggregate functions, then the result set has only one row giving the aggregate values calculated from the source rows that match the WHERE clause predicates.

scheduled backup

An automatic backup accomplished by SQL Server Agent when defined and scheduled as a job.

schema

In the SQL-92 standard, a collection of database objects that are owned by a single user and form a single namespace. A namespace is a set of objects that cannot have duplicate names. For example, two tables can have the same name only if they are in separate schemas, no two tables in the same schema can have the same name. In Transact-SQL, much of the functionality associated with schemas is implemented by database user IDs. In database tools, schema also refers to the catalog information that describes the objects in a schema or database. In Analysis Services, a schema is a description of multidimensional objects such as cubes and dimensions.

schema rowset

A special OLE DB or Analysis Services rowset that reports catalog information for objects in databases or multidimensional cubes. For example, the OLE DB schema rowset DBSCHEMA_COLUMNS describes columns in tables, and the Analysis Services MDSCHEMA_MEASURES schema rowset describes the measures in a cube.

script

A collection of Transact-SQL statements used to perform an operation. Transact-SQL scripts are stored as files, usually with the .sql extension.

scroll

The ability to move around a cursor in directions other than forward-only. Users can move up and down the cursor.

search condition

In a WHERE or HAVING clause, predicates that specify the conditions that the source rows must meet to be included in the SQL statement. For example, the statement SELECT * FROM Employees WHERE Title = 'Sales Representative' returns only those rows that match the search condition: Title = 'Sales Representative'.

Security Identifier (SID)

A unique value that identifies a user who is logged on to the security system. SIDs can identify either one user or a group of users.

segmentation

A data mining technique that analyzes data to discover mutually exclusive collections of records that share similar attributes sets. A segmentation algorithm can use unsupervised learning techniques such as clustering or supervised learning for a specific prediction field.

See also: clustering

SELECT

The Transact-SQL statement used to return data to an application or another Transact-SQL statement, or to populate a cursor. The SELECT statement returns a tabular result set consisting of data that is typically extracted from one or more tables. The result set contains only data from rows that match the search conditions specified in WHERE or HAVING clauses.

SELECT

In Analysis Services, the Multidimensional Expressions (MDX) statement used to query cubes and return recordsets of multidimensional data.

select list

The SELECT statement clause that defines the columns of the result set returned by the statement. The select list is a comma-separated list of expressions, such as column names, functions, or constants.

Select query

A query that returns rows into a result set from one or more tables. A Select query can contain specifications for those columns to return, the rows to select, the order to put the rows in, and how to group (summarize) information.

self-join

A join in which records from a table are combined with other records from the same table when there are matching values in the joined fields. A self-join can be an inner join or an outer join. In database diagrams, a self-join is called a reflexive relationship.

semantic object

An object that can be represented by a database object or other real-world object. For example, an entity and a relationship are semantic objects.

semiadditive measure

A measure that can be summed along one or more, but not all, dimensions in a cube. For example, a quantity-on-hand measure of inventory can be summed along the geography dimension to produce a total quantity on hand for all warehouses, but it cannot be summed along the time dimension because the measure specifies snapshot quantities periodically in time.

sensitive cursor

A cursor that can reflect data modifications made to underlying data by other users while the cursor is open. Updates, deletes, and inserts made by other users are reflected in the sensitive cursor. Sensitive cursors are typically used in Transact-SQL batches, stored procedures, and triggers by omitting the INSENSITIVE keyword on the DECLARE CURSOR statement.

sequence

See definition for: identity column

sequenced collection

A collection of destination objects of a sequenced relationship object.

See also: sequenced relationship

sequenced relationship

A relationship in a repository that specifies explicit positions for each destination object within the collection of destination objects.

See also: relationship object, origin object, sequenced collection

serializable

The highest transaction isolation level. Serializable transactions lock all rows they read or modify to ensure the transaction is completely isolated from other tasks. This guarantees that a series of serializable transactions will always produce the same results if run in the same sequence.

server cursor

A cursor implemented on the server. The cursor itself is built at the server, and only the rows fetched by an application are sent to the client.

See also: API server cursor

server name

A name that uniquely identifies a server computer on a network. SQL Server applications can connect to a default instance of SQL Server by specifying only the server name. SQL Server applications must specify both the server name and instance name when connecting to a named instance on a server.

session

In English Query, a sequence of operations performed by the English Query engine. A session begins when a user logs on and ends when the user logs off. All operations during a session form one transaction scope and are subject to permissions determined by the logon username and password.

Setup initialization file

A text file, using the Windows .ini file format, that stores configuration information allowing SQL Server to be installed without a user having to be present to respond to prompts from the Setup program.

severity level

A number indicating the relative significance of an error generated by the SQL Server database engine. Values range from informational (1) to severe (25).

shared dimension

A dimension created within a database that can be used by any cube in the database.

See also: private dimension

shared lock

A lock created by nonupdate (read) operations. Other users can read the data concurrently, but no transaction can acquire an exclusive lock on the data until all the shared locks have been released.

Showplan

A report showing the execution plan for an SQL statement. SET SHOWPLAN_TEXT and SET SHOWPLAN_ALL produce textual showplan output. SQL Query Analyzer and SQL Server Enterprise Manager can display showplan information as a graphical tree.

sibling

A member in a dimension hierarchy that is a child of the same parent as a specified member. For example, in a Time dimension with Year and Month levels, the members January 1997 and February 1997 are siblings.

See also: ancestor, child, descendant, parent

SID

See definition for: Security Identifier (SID)

single-user mode

A state in which only one user can access a resource. Both SQL Server instances and individual databases can be put into single-user mode.

slice

A subset of the data in a cube, specified by limiting one or more dimensions by members of the dimension. For example, facts for a particular year constitute a slice of multiyear data.

See also: axis

smalldatetime data type

Date and time data from January 1, 1900, through June 6, 2079, with an accuracy of one minute.

smallint data type

SQL Server system integer data from -2^15 (-32,768) through 2^15 - 1 (32,767).

smallmoney data type

A SQL Server system data type that stores monetary values from -214,748.3648 through +214,748.3647, with accuracy to a ten-thousandth of a monetary unit. Storage size is 4 bytes. When smallmoney values are displayed, they are rounded up two places.

Snapshot Agent

Prepares snapshot files containing schema and data of published tables, stores the files in the snapshot folder, and inserts synchronization jobs in the publication database.

Snapshot Agent utility

Configures and triggers the Snapshot Agent, which prepares snapshot files containing schema and data of published tables and database objects.

snapshot cursor

See definition for: static cursor

snapshot replication

A type of replication that distributes data exactly as it appears at a specific moment in time and does not monitor for modifications made to the data.

See also: merge replication, transactional replication

snowflake schema

An extension of a star schema such that one or more dimensions are defined by multiple tables. In a snowflake schema, only primary dimension tables are joined to the fact table. Additional dimension tables are joined to primary dimension tables.

See also: star schema, primary dimension table

solve order

The order of evaluation (from highest to lowest solve order) and calculation (from lowest to highest solve order) for calculated members, custom members, custom rollup formulas, and calculated cells in a single calculation pass of a multidimensional cube. Solve order is used to determine formula precedence when calculating values for cells in multidimensional cubes, but only within a single calculation pass.

See also: pass order, calculation subcube, calculation pass, calculation condition, calculation formula

sort order

The set of rules in a collation that define how characters are evaluated in comparison operations and the sequence in which they are sorted.

source and target

A browsing technique in which a source object is used to retrieve its target object or objects through their relationship.

source cube

The cube on which a linked cube is based.

See also: linked cube

source database

See definition for: publication database

source database

In data warehousing, the database from which data is extracted for use in the data warehouse.

source object

The single object to which all objects in a particular collection are connected by way of relationships that are all of the same relationship type. For destination collections, the source object is the destination object. For origin collections, the source object is the origin object.

source partition

An Analysis Services partition that is merged into another and is deleted automatically at the end of the merger process.

See also: target partition

sparsity

The relative percentage of a multidimensional structure's cells that do not contain data. Analysis Services stores only cells that contain data. A sparse cube requires less storage than a dense cube of identical structure design.

See also: data explosion, density

SQL

See definition for: Structured Query Language (SQL)

SQL collation

A set of SQL Server 2000 collations whose characteristics match those of commonly-used code page and sort order combinations from earlier versions of SQL Server. SQL collations are compatibility features that let sites choose collations that match the behavior of their earlier systems.

See also: collation

SQL database

A database based on Structured Query Language (SQL).

SQL expression

Any combination of operators, constants, literal values, functions, and names of tables and fields that evaluates to a single value. For example, use expressions to define calculated fields in queries.

SQL Mail

A component of SQL Server that allows SQL Server to send and receive mail messages through the built-in Windows NT or Windows 2000 Messaging Application Programming Interface (MAPI). A mail message can consist of short text strings, the output from a query, or an attached file.

SQL query

An SQL statement, such as SELECT, INSERT, UPDATE, DELETE, or CREATE TABLE.

SQL Server Authentication

One of two mechanisms for validating attempts to connect to instances of SQL Server. Users must specify a SQL Server login ID and password when they connect. The SQL Server instance ensures the login ID and password combination are valid before allowing the connection to succeed. Windows authentication is the preferred authentication mechanism.

See also: authentication, Windows Authentication

SQL Server Event Forwarding Server

A central instance of SQL Server that manages SQL Server Agent events forwarded to it by other instances. Enables central management of SQL Server events.

SQL Server login

An account stored in SQL Server that allows users to connect to SQL Server.

SQL Server role

See definition for: role

SQL Server user

See definition for: user (account)

SQL statement

An SQL or Transact-SQL command, such as SELECT or DELETE, that performs some action on data.

SQL-92

The version of the SQL standard published in 1992. The international standard is ISO/IEC 9075:1992 Database Language SQL. The American National Standards Institute (ANSI) also published a corresponding standard (Data Language SQL X3.135-1192), so SQL-92 is sometimes referred to as ANSI SQL in the United States.

sql_variant data type

Data type that stores values of various SQL Server-supported data types except text , ntext , timestamp , and sql_variant .

standard security

See definition for: SQL Server Authentication

star join

A join between a fact table (typically a large fact table) and at least two dimension tables. The fact table is joined with each dimension table on a dimension key. SQL Server considers special index manipulation strategies on these queries to minimize access to the fact table.

An example of a schema participating in a star join query could be a sales table, the fact table (containing millions of rows), a product table, (containing the description of several hundred products), and a store table (containing several dozen store names). In this example, the product and store tables are dimension tables. A query for selecting sales data for a small set of stores and a subset of products restricted by attributes not present in the sales database is an ideal candidate for the star query optimization.

See also: fact table

star schema

A relational database structure in which data is maintained in a single fact table at the center of the schema with additional dimension data stored in dimension tables. Each dimension table is directly related to and usually joined to the fact table by a key column. Star schemas are used in data warehouses.

See also: denormalize, fact table, snowflake schema

statement permission

An attribute that controls that controls whether a user can execute CREATE or BACKUP statements.

static cursor

A cursor that shows the result set exactly as it was at the time the cursor was opened. Static cursors do not reflect updates, deletes, or inserts made to underlying data while the cursor is open. They are sometimes called snapshot cursors.

static SQL statements

In Embedded SQL for C, an SQL statement that is built at the time the application is compiled. It is created as a stored procedure when the application is compiled, and the stored procedure is executed when the application is run.

step object

A Data Transformation Services (DTS) object that coordinates the flow of control and execution of tasks in a DTS package. A task that does not have an associated step object is never executed.

store-and-forward database

See definition for: distribution database

stored procedure

A precompiled collection of Transact-SQL statements stored under a name and processed as a unit. SQL Server supplies stored procedures for managing SQL Server and displaying information about databases and users. SQL Server-supplied stored procedures are called system stored procedures.

string

A set of contiguous bytes that contain a single character-based or binary data value. In character strings, each byte, or pair of bytes, represents a single alphabetic letter, special character, or number. In binary strings, the entire value is considered to be a single stream of bits that do not have any inherent pattern. For example, the constant 'I am 32.' is an 8 byte character string, while the constant 0x0205efa3 is a 4 byte binary string.

string functions

Functions that perform operations on character or binary strings. Built-in string functions return values commonly needed for operations on character data.

Structured Query Language (SQL)

A language used to insert, retrieve, modify, and delete data in a relational database. SQL also contains statements for defining and administering the objects in a database. SQL is the language supported by most relational databases, and is the subject of standards published by the International Standards Organization (ISO) and the American National Standards Institute (ANSI). SQL Server 2000 uses a version of the SQL language called Transact-SQL.

structured storage file

See definition for: COM-structured storage file

subject

A basic grammatical division of a sentence. The subject is a noun or noun clause about which something is asserted or asked in the predicate, which it usually precedes. For example, in the sentence "The employee placed the order," the word employee is the subject of the sentence.

subquery

A SELECT statement nested inside another SELECT, INSERT, UPDATE, or DELETE statement, or inside another subquery.

subscribe

To request data from a Publisher.

Subscriber

A server that receives copies of published data.

subscribing server

An Analysis server that stores a linked cube.

See also: publishing server, linked cube

subscription

An order that defines what data will be published, when, and to what Subscriber.

subscription database

A database at the Subscriber that receives data and database objects published by a Publisher.

subset

A selection of tables and the relationship lines between them that is part of a larger database diagram. This selection can be copied to a new database diagram. This is called subsetting the diagram.

subset phrasing

A way of expressing a relationship in English in which one entity or word is a subset of another entity. For example, in the sentence "Some mountains are volcanoes", volcanoes are a subset of mountains.

superlative form

A form of an adverb or adjective that refers to a comparison or denotes the greatest degree. Shorter adjectives and some adverbs typically form their superlative degree by adding -est, as youngest or strongest.

synchronization

In replication, the process of maintaining the same schema and data at a Publisher and at a Subscriber.

See also: initial snapshot

synonym

A word that means the same thing as another word. For example, workers can be a synonym for employees .

system administrator

The person or group of people responsible for managing an instance of SQL Server. System administrators have full permissions to perform all actions in an instance of SQL Server. System administrators are either members of the sysadmin fixed server role, or log in using the sa login ID.

system catalog

A set of system tables that describe all the features of an instance of SQL Server. The system catalog records meta data such as the definitions of all users, all databases, all objects in each database, and system configuration information such as server and database option settings.

See also: database catalog

system databases

A set of four databases present in all instances of SQL Server that are used to store system information:

The master database stores all instance-level meta data, and records the location of all other databases.

The tempdb database stores transient objects that only exist for the length of a single statement or connection, such as worktables and temporary tables or stored procedures.

The model database is used as a template for creating all user databases.

The msdb database is used by the SQL Server Agent to record information on jobs, alerts, and backup histories.

See also: user database

system functions

A set of built-in functions that perform operations on and return the information about values, objects, and settings in SQL Server.

system stored procedures

A set of SQL Server-supplied stored procedures that can be used for actions such as retrieving information from the system catalog or performing administration tasks.

system tables

Built-in tables that form the system catalog for SQL Server. System tables store all the meta data for an instance of SQL Server, including configuration information and definitions of all the databases and database objects in the instance. Users should not directly modify any system table.

T

table

A two-dimensional object, consisting of rows and columns, used to store data in a relational database. Each table stores information about one of the types of objects modeled by the database. For example, an education database would have one table for teachers, a second for students, and a third for classes.

The columns of a table represent an attribute of the modeled object (for example, first name, last name, and address). Each row represents one occurrence of the modeled object. For example, one row in the Class table would record the information about an Algebra 1 class taught at 9:00 A.M. and another would record the information about a World History class taught at 10:00 A.M.

table data type

A special data type used to store a result set for later processing.

table lock

A lock on a table including all data and indexes.

table scan

A data retrieval operation where the database engine must read all the pages in a table to find the rows that qualify for a query.

table-level constraint

Constraints that allow various forms of data integrity to be defined on one column (column-level constraint) or several columns (table-level constraints) when the table is defined or altered. Constraints support domain integrity, entity integrity, and referential integrity, as well as user-defined integrity.

tabular data stream (TDS)

The SQL Server internal client/server data transfer protocol. TDS allows client and server products to communicate regardless of operating-system platform, server release, or network transport.

tape backup

A backup operation to any tape device supported by Windows NT 4.0 and Windows 2000. If you are creating a tape backup file, you must first install the tape device by using Windows NT 4.0 and Windows 2000. The tape device must be physically attached to the SQL Server you are backing up.

target object

See definition for: source and target

target partition

An Analysis Services partition into which another is merged and which contains the data of both partitions after the merger.

See also: source partition

task

See definition for: job

task object

A Data Transformation Services (DTS) object that defines pieces of work to be performed as part of the data transformation process. For example, a task can execute an SQL statement or move and transform heterogeneous data from an OLE DB source to an OLE DB destination using the DTS Data Pump.

TDS

See definition for: tabular data stream (TDS)

tempdb database

The database that provides a storage area for temporary tables, temporary stored procedures, and other temporary working storage needs.

temporary stored procedure

A procedure placed in the temporary database, tempdb , and erased at the end of the session.

temporary table

A table placed in the temporary database, tempdb , and erased at the end of the session.

text data type

A SQL Server system data type that specifies variable-length non-Unicode data with a maximum length of 2^31 -1 (2,147,483,647) characters. The text data type cannot be used for variables or parameters in stored procedures.

theta join

A join based on a comparison of scalar values (=, > , >= , < , <= , < >, !<, !>).

thread

An operating system component that allows the logic of multiuser applications to be performed as several separate, asynchronous execution paths. The SQL Server relational database engine executes multiple threads in order to make use of multiple processors. The use of threads also helps ensure that work is being performed for some user connections even when other connections are blocked (for example, when waiting for a disk read or write operation to complete).

time dimension

A dimension that breaks time down into levels such as Year, Quarter, Month, and Day. In Analysis Services, a special type of dimension created from a date/time column.

timestamp data type

A SQL Server system data type that is a monotomically increasing counter whose values are always unique within a database.

tinyint data type

A SQL Server system data type that holds whole numbers from 0 through 255. Its storage size is 1 byte.

tool

A SQL Server application with a graphical user interface used to perform common tasks.

trace file

A file used by SQL Profiler to record monitored events.

training data set

A set of known and predictable data used to train a data mining model.

See also: mining model training

trait

An attribute that describes an entity. For example, blood-type is a trait of patients.

trait phrasing

A way of expressing a relationship in English description in which a minor entity describes a major entity. For example, in the phrase, ages of customers, ages is the trait (or minor entity), and customers is the major entity.

Transact-SQL

The language containing the commands used to administer instances of SQL Server, create and manage all objects in an instance of SQL Server, and to insert, retrieve, modify and delete all data in SQL Server tables. Transact-SQL is an extension of the language defined in the SQL standards published by the International Standards Organization (ISO) and the American National Standards Institute (ANSI).

Transact-SQL cursor

A server cursor defined by using the Transact-SQL DECLARE CURSOR syntax. Transact-SQL cursors are intended for use in Transact-SQL batches, stored procedures, and triggers.

transaction

A group of database operations combined into a logical unit of work that is either wholly committed or rolled back. A transaction is atomic, consistent, isolated, and durable.

transaction log

A database file in which all changes to the database are recorded. It is used by SQL Server during automatic recovery.

transaction processing

Data processing used to efficiently record business activities, called transactions, that are of interest to an organization (for example, sales, orders for supplies, or money transfers). Typically, online transaction processing (OLTP) systems perform large numbers of relatively small transactions.

transaction rollback

Rollback of a user-specified transaction to the last savepoint inside a transaction or to the beginning of a transaction.

transactional replication

A type of replication where an initial snapshot of data is applied at Subscribers, and then when data modifications are made at the Publisher, the individual transactions are captured and propagated to Subscribers.

See also: merge replication, snapshot replication

transformable subscription

A subscription that allows data movement, transformation mapping, and filtering capabilities of Data Transformation Services (DTS) during replication.

transformation

In data warehousing, the process of changing data extracted from source data systems into arrangements and formats consistent with the schema of the data warehouse.

trigger

A stored procedure that executes when data in a specified table is modified. Triggers are often created to enforce referential integrity or consistency among logically related data in different tables.

trusted connection

A Windows network connection that can be opened only by users who have been authenticated by the network. The users are identified by their Windows login ID and do not have to enter a separate SQL Server login ID.

See also: Windows Authentication

tuple

An ordered collection of members from different dimensions. For example, (Boston, [1995]) is a tuple formed by members of two dimensions: Geography and Time. A single member is a degenerated case of a tuple and can be used as an expression without the parentheses.

See also: axis

two-phase commit

A process that ensures transactions that apply to more than one server are completed on all servers or on none.

U

unbalanced hierarchy

A dimension hierarchy in which leaf nodes differ in their distances from the root node. Component part and organization chart hierarchies are usually unbalanced.

See also: ragged hierarchy

underlying table

A table referenced by a view, cursor, or stored procedure.

See also: base table

unenforced relationship

A link between tables that references the primary key in one table to a foreign key in another table, and which does not check the referential integrity during INSERT and UPDATE transactions. An unenforced relationship is represented in a database diagram by a dashed line.

Unicode

Unicode defines a set of letters, numbers, and symbols that SQL Server recognizes in the nchar , nvarchar , and ntext data types. It is related to but separate from character sets. Unicode has more than 65,000 possible values compared to a character set's 256, and takes twice as much space to store. Unicode includes characters for most languages.

Unicode collation

This acts as a sort order for Unicode data. It is a set of rules that determines how SQL Server compares, collates, and presents Unicode data in response to database queries.

Unicode format

Data stored in a bulk copy data file using Unicode characters.

Union query

A query that combines two tables by performing the equivalent of appending one table onto the other.

UNIQUE constraints

Constraints that enforce entity integrity on a nonprimary key. UNIQUE constraints ensure that no duplicate values are entered and that an index is created to enhance performance.

unique index

An index in which no two rows are permitted to have the same index value, thus prohibiting duplicate index or key values. The system checks for duplicate key values when the index is created and checks each time data is added with an INSERT or UPDATE statement.

uniqueidentifier data type

A data type containing a unique identification number stored as a 16-byte binary string used for storing a globally unique identifier (GUID).

update

The act of modifying one or more data values in an existing row or rows, typically by using the UPDATE statement. Sometimes, the term update refers to any data modification, including insert, update, and delete operations.

update lock

A lock placed on resources (such as row, page, table) that can be updated. Updated locks are used to prevent a common form of deadlock that occurs when multiple sessions are locking resources and are potentially updating them later.

Update query

A query that changes the values in columns of one or more rows in a table.

update statistics

A process that recalculates information about the distribution of key values in specified indexes. These statistics are used by the query optimizer to determine the most efficient way to execute a query.

user (account)

A SQL Server security account or identifier that represents a specific user in a database. Each user's Windows account or SQL Server login is mapped to a user account in a database. Then, the appropriate permissions are granted to the user account. Each user account can only access data with which it has been granted permission to work.

user database

A database created by a SQL Server user and used to store application data. Most users connecting to instances of SQL Server reference user databases only, not system databases.

See also: system databases

user-defined data type

A data type, based on a SQL Server data type, created by the user for custom data storage. Rules and defaults can be bound to user-defined data types (but not to system data types).

See also: base data type

user-defined event

A type of message, defined by a user, that can be traced by SQL Profiler or used to fire a custom alert. Typically, the user is the system administrator.

user-defined function

In Analysis Services, a function defined in a Microsoft ActiveX library created using a Component Object Model (COM) automation language such as Visual Basic or Visual C++. Such libraries can be registered with Analysis Services and their functions called from Multidimensional Expressions (MDX) queries.

user-defined function

In SQL Server, a Transact-SQL function defined by a user. Functions encapsulate frequently performed logic in a named entity that can be called by Transact-SQL statements instead of recoding the logic in each statement.

utility

A SQL Server application run from a command prompt to perform common tasks.

V

value expression

An expression in Multidimensional Expressions (MDX) that returns a value. Value expressions can operate on sets, tuples, members, levels, numbers, or strings. For example, set value expressions operate on member, tuple, and set elements to yield other sets.

varbinary data type

A SQL Server system data type that holds up to 8,000 bytes of variable-length binary data.

varchar data type

A SQL Server system data type that holds variable-length non-Unicode data with a maximum of 8,000 characters.

variables

Defined entities that are assigned values. A local variable is defined with a DECLARE@localvariable statement and assigned an initial value within the statement batch where it is declared with either a SELECT or SET@localvariable statement.

verb

A part of speech denoting action, occurrence, or existence. A verb can consist of one or more words. For example, verbs appear in italics in the following sentences:

Employees sell products.

Employees will be working late.

verb phrasing

A way of expressing a relationship in English in which one entity is the subject in an action, which is expressed with a verb. For example, customers buy products. ( Customers is the entity; buy is the verb, and products is the direct object.)

vertical filtering

Filtering columns from a table. When used as part of replication, the table article created contains only selected columns from the publishing table.

See also: filtering, vertical partitioning

vertical partitioning

To segment a single table into multiple tables based on selected columns. Each of the multiple tables has the same number of rows but fewer columns.

See also: partitioning, vertical filtering

very large dimension

In Analysis Services, a dimension that contains more than approximately five million members and less than approximately ten million members. Special techniques are used to process very large dimensions.

See also: huge dimension

view

A database object that can be referenced the same way as a table in SQL statements. Views are defined using a SELECT statement and are analogous to an object that contains the result set of this statement.

view generation

A repository engine feature that is used to create relational views based on classes, interfaces, and relationships in an information model.

virtual cube

A logical cube based on one or more regular cubes or linked cubes.

virtual dimension

A logical dimension that is based on the values of properties of members of a physical dimension. For example, a virtual dimension that contains the colors red, green, and blue can be based on the Color member property of a product dimension.

See also: member property, dimension, member

visual total

A displayed, aggregated cell value for a dimension member that is consistent with the displayed cell values for its displayed children. The visual total of a cell can vary from the actual total if some children of the cell are hidden. For example, if the aggregate function is SUM, the displayed cell value for Spain is 1000, and the displayed cell value for Portugal is 2000, the visual total for Iberia is 3000.

W

WHERE clause

The part of an SQL statement that specifies which records to retrieve.

wildcard characters

Characters, including underscore (_), percent (%), and brackets ([ ]), used with the LIKE keyword for pattern matching.

wildcard search

The use of placeholders (such as * or ?) to perform a search for data in a table or field. For example, searching the Last Name field in a database using Smith*, could result in finding all records in which the last name starts with Smith, including Smith, Smithson, Smithlin, and so forth.

Windows Authentication

One of two mechanisms for validating attempts to connect to instances of SQL Server. Users are identified by their Windows user or group when they connect. Windows Authentication is the most secure mechanism for connecting to SQL Server.

See also: SQL Server Authentication, trusted connection

Windows collation

A set of rules that determines how SQL Server sorts character data. It is specified by name in the Windows Control Panel and in SQL Server 2000 during Setup.

word generation

Process of determining other forms of the word(s) specified. The Microsoft Search Service currently implements inflectional word generation. For example, if the word swim is specified, SQL Server also searches for swim , swam , and swimming .

write back

To update a cube cell value, member, or member property value.

See also: write enable

write enable

To change a cube or dimension so that users in cube roles with read/write access to the cube or dimension can change its data.

See also: write back

write-ahead log

A transaction logging method in which the log is always written prior to the data.

X

There are no glossary terms that begin with this letter.

Y

There are no glossary terms that begin with this letter.

Z

There are no glossary terms that begin with this letter.