Attach Subscription

The attachable subscription databases feature allows you to transfer a database with published data and subscriptions from one Subscriber to another. After the database is attached to the new Subscriber, the database at the new Subscriber automatically receives its own pull subscriptions to the publications at those Publishers. The publication must enable copying for a subscription database to be copied and attached to another Subscriber.

The following options are available on the Attach Subscription tab of the Windows Synchronization Manager.

Options

Subscription database file:

Enter the path and file name for the .msf subscription database file to attach to this Subscriber.

(...)

Browse for the .msf subscription database file to attach to this Subscriber.

Subscriber

Enter the computer name for the Subscriber.

Database

Enter the name of the subscription database that will receive replicated data.

Use Windows Authentication of the current user's account

Select this option if you will use Windows Authentication to connect to the Subscriber.

Use SQL Server Authentication

Select this option if you will use SQL Server Authentication with login and password to connect to the Subscriber.

Login

Enter the login used when connecting to the Subscriber.

Password

Enter the password used when connecting to the Subscriber.

Confirm password

Enter the password to confirm the spelling.


Create Anonymous Subscription

An anonymous subscription is a type of pull subscription for which detailed information about the subscription and the Subscriber is not stored. Initiated at the Subscriber, the Subscriber is responsible for keeping an anonymous subscription synchronized.

The following options are available on the Create Anonymous Subscription tab of the Windows Synchronization Manager.

Options

Display name

Enter the name for the anonymous subscription.

Subscriber

Enter the computer name for the Subscriber.

Database

Enter the name of the subscription database that will receive replicated data.

Publisher

Enter the computer name for the Publisher.

Database

Enter the publication database that is the source for the published data.

Publication

Enter the name of the publication to which this subscription will subscribe.

Type

Click the drop-down arrow and select the type of publication (snapshot publication, transactional publication, or merge publication).

Distributor

Enter the computer name of the Distributor.


Create Anonymous Subscription (Browse the Active Directory)

An anonymous subscription is a type of pull subscription for which detailed information about the subscription and the Subscriber is not stored. Initiated at the Subscriber, the Subscriber is responsible for keeping an anonymous subscription synchronized. Using Microsoft® Windows® 2000 Active Directory™ Services, you can view replication objects, such as a publication, and, if allowed, subscribe to that publication.

The following options are available on the Create Anonymous Subscription tab of the Windows Synchronization Manager.

Options

Publication

View the name of publications that are listed in Active Directory.

Browse (...)

Click to browse for publications listed in Active Directory.

Subscriber

Enter the computer name of the Subscriber.

Database

Enter the name of the subscription database that will receive the replicated data.

Use Windows Authentication of the current user's account

Select this option if you will use Windows Authentication to connect to the Subscriber.

Use SQL Server Authentication

Select this option if you will use SQL Server Authentication with login and password to connect to the Subscriber.

Login

Enter the login used when connecting to the Subscriber.

Password

Enter the password used when connecting to the Subscriber.

Confirm password

Enter the password to confirm the spelling.


SQL Server Subscription Properties, Identification Tab

This tab allows you to change the name for the subscription, choose alternate synchronization partners for merge subscriptions, and reinitialize or remove the subscription.

The following options are available on the SQL Server Subscription Properties, Identification tab of the Windows Synchronization Manager.

Options

Display name

View or enter the name for the anonymous subscription.

Subscriber

View the computer name for the Subscriber.

Subscription Database

View the name of the subscription database that will receive replicated data.

Publisher

Select the computer name for the Publisher that will synchronize this subscription. Subscribers to merge publications can synchronize with servers other than the Publisher at which the subscription originated. Synchronizing with alternate partners provides the ability for a Subscriber to synchronize data even if the primary Publisher is unavailable. This feature is also useful when mobile Subscribers have access to a faster or more reliable network connection with an alternate synchronization partner.The alternate synchronization partner must have the data and schema required by the subscription. It is recommended that the publication created on the alternate server be a clone of the publication created on the original Publisher. The publication properties must specify that Subscribers can synchronize with other Publishers.

Publication Database

View the publication database that is the source for the published data.

Publication name

View the name of the publication to which this subscription will subscribe.

Distributor

View the computer name of the Distributor.

Publication type

View the type of publication (snapshot publication, transactional publication, or merge publication).


SQL Server Subscription Properties, Other Tab

The following options are available on the SQL Server Subscription Properties, Other tab of the Windows Synchronization Manager.

Options

Login timeout

Specify the amount of time to wait for a connection before timing out.

Query timeout

Specify the amount of time a query can process before timing out.

Resolve conflicts interactively (only applies to articles that support interactive resolution)

Select to resolve conflicts interactively. Microsoft SQL Server replication provides an interactive resolver, which allows you to resolve conflicts manually during on-demand synchronization. Activated at run-time, the Interactive Resolver displays data for each conflicting row, and provides options for viewing and editing the conflict data, and resolving each conflict individually. The article must be enabled to support interactive resolution. This option is displayed only for subscriptions to merge publications.

Resolve conflicts automatically

Select to have SQL Server resolve conflicts automatically based on the conflict resolution policy of the publication. This option is displayed only for subscriptions to merge publications.

Subscriber update mode

Select immediate updating or queued updating as the method for which data modifications made at the Subscriber will be propagated to the Publisher. This option is displayed only for subscriptions to snapshot or transactional publications that allow immediate updating with queued updating as a failover. Immediate updating with queued updating as a failover can be used when you expect the Publisher and Subscribers to be connected, but you do not want to lose the ability to make updates at the Subscriber if a system failure results in the loss of network connectivity. Immediate updating with queued updating as a failover allows you to use immediate updating and switch to queued updating when needed.