Bienvenido

Bienvenido a Inn from Excel

El deseo de cualquier gerente estará realizado en este nuevo módulo de Inn Suite. Inn from Excel ver 2.0, le brinda la posibilidad real de confeccionar directamente desde una hoja de cálculo de Microsoft Excel, los reportes gerenciales más diversos y completos, con la información almacenada en cualquiera de los módulos que componen Inn Suite. Con este módulo usted tendrá en su hoja de cálculo, un conjunto de funciones, para acceder directamente y de manera online, a la información que usted necesita y en la forma que usted requiera, con la que podrá obtener un máximo de eficiencia y control en su empresa.

Contáctenos: www.integra-hotel.com

info@integra-hotel.com

Todos los derechos reservados


Instalación

A continuación se detallan los pasos a seguir para la instalación en cada una de la estaciones de trabajo de InnfromExcel.

  1. Abrir un nuevo documento en Microsoft Excel.

  2. Ir al Menú de Herramientas, Opción Complementos y en este formulario hacer click en el botón examinar, buscar en el servidor la carpeta compartida para complementos "InnfromExcel" y seleccionar el archivo: "Inn Suite from Excel.xla".

A partir de que se activa el complemento, se incorpora un nuevo menú llamado "InnSuite", al menú de Microsoft Excel, en el cual están todas las funciones disponibles.

Nota: En caso de que se produzca algún error cuando se active el complemento se deberá ejecutar el programa de Instalación de Componentes de Acceso a Datos: "Mdac_typ", seleccionando instalación típica, que se encuentra en el directorio "utils" del CD de Instalación de InnSuite.


Sintaxis/Parametros

En esta sección se describen una serie de reglas y formatos que se siguieron en el desarrollo de cada una de las funciones de usuarios que brinda InnfromExcel. Estas reglas se aplican a todas las funciones disponibles y ayudarán a una mejor comprensión de las mismas así como a prevenir posibles errores de usuario.

  1. Todas las funciones del Módulo de FrontDesk comienzan con "fro_".

  2. Todas las funciones del Módulo de Puntos de Ventas comienzan con "pos_".

  3. Todas las funciones del Módulo de Contabilidad comienzan con "acc_".

  4. Todas las funciones del Módulo de Comunicaciones comienzan con "com_".

  5. El llamado a las funciones es similar a como se llamaría cualquier función de Microsoft Excel, teniendo las posibilidades de realizar la inserción de las mismas, ya sea por el menú incorporado de InnSuite a Microsoft Excel o por los formularios de Microsoft Excel para inserción y edición de funciones.

  6. En todas las funciones hay parámetros que son obligatorios y otros que son opcionales. Los parámetros opcionales se usarían en el caso de que se quiera realizar un filtro de la información que se va a procesar o calcular.

  7. Cuando se especifica que un parámetro de la función es obligatorio, implica que siempre se tendrá que pasar un valor en el mismo.

  8. Cuando se especifica que un parámetro de la función es opcional, implica que se puede especificar un valor ó se puede pasar una cadena vacía (Ej: ""). Nunca se puede dejar sin valor.

  9. El valor de los parámetros de una función puede ser una referencia a otra celda, siempre y cuando coincida el tipo de datos que especifica dicho parámetro con el tipo de datos que contiene la celda de referencia.

  10. El tipo de Datos que se debe especificar en cada uno de los parámetros de una función se puede reconocer por la primera letra de la descripción de los mismos, que se inserta al hacer click en la función deseada en el menú de InnSuite. A continuación se detalla el significado de los mismos:

    • Si el parámetro comienza con la letra "c": Es del tipo de datos cadena de caracteres, por lo que el valor que se pase tendrá que estar entre comillas dobles o hacer referencia a una celda. Ej.: "Enero", "TARIFAPROMEDIO", "CAMINO TRAVEL", "", etc.

    • Si el parámetro comienza con la letra "d": Es del tipo de datos Fecha, por lo que el valor que se pase tendrá que estar entre comillas dobles o hacer referencia a una celda. Muy importante, el formato para especificar las fechas es el formato Americano: mm/dd/aaaa Ej.: "12/31/2004", "01/01/2005", etc.

    • Si el parámetro comienza con la letra "n": Es del tipo de datos numérico, por lo que el valor que se pase no tendrá que estar entre comillas dobles o puede hacer referencia a una celda. Ej.: 2004, 2005, etc.


Nuevo en esta Versión

Que hay de Nuevo en esta Versión

Versión 2.0 de Inn from Excel: Se agregaron las siguientes funciones:

2 nuevas Funciones de Telefonía: Estas calculan los ingresos por llamadas telefónicas de un grupo de tarifas específico.

6 nuevas Funciones de Telefonía: Estas calculan los costos por llamadas telefónicas de un grupo de tarifas específico, ya sea general, de llamadas cobradas o de llamadas no cobradas.

6 nuevas Funciones de Telefonía: Estas calculan la duración en minutos por llamadas telefónicas de un grupo de tarifas específico, ya sea general, de llamadas cobradas o de llamadas no cobradas.

Versión 1.5 de Inn from Excel: Se agregaron y se mejoraron las siguientes funciones:

Se agregaron 4 nuevas Funciones de FrontDesk: Estas calculan los datos relativos a entradas y estancias de habitaciones fuera de orden.

Se modificaron las funciones de estancias y entradas tanto de clientes como de habitaciones a las cuales se les agrego un parámetro de filtrado por nacionalidad.

Se modificaron las funciones de estancias y entradas tanto de clientes como de habitaciones para que tengan en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Se modificaron las funciones de ingresos de hospedaje y ayb para que tengan en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Versión 1.0 de Inn from Excel:

Funciones de FrontDesk: 18 Funciones que abarcan: Habitaciones/Clientes, Estadísticas de Composiciones, Estadísticas de Ingresos y Estadísticas de Ocupación.

Funciones de Puntos de Ventas: 24 Funciones que abarcan: Generales, Ventas, Descuentos, Recargos, Artículos y Clientes.

Funciones de Contabilidad: 12 Funciones que abarcan: Generales, Cuentas y Presupuestos.

Funciones de Telefonía: 16 Funciones que abarcan: Ingresos por Llamada, Costos por Llamadas y Duración de Llamadas.


Estado de una Habitación para una Fecha

Descripción: Función que devuelve el estado de una habitación para una fecha pasada como parámetro.

Sintaxis: =fro_Estado_Habit_Fecha(cCodHabit,dFecha)

Descripción de Parámetros:

cCodHabit: (Obligatorio) Código de la Habitación.

dFecha : (Obligatorio) Fecha para la cual se desea saber el estado de la habitación.

Comentarios: Devuelve 0 si la habitación no estuvo ocupada, devuelve 1 si la habitación estuvo ocupada

Ejemplos:


Nombre del Cliente en la Habitación para una Fecha

Descripción: Función que devuelve el nombre del cliente que estuvo hospedado en una habitación para una fecha pasada como parámetro.

Sintaxis: = fro_Cliente_Habit_Fecha(cCodHabit,dFecha)

Descripción de Parámetros:

cCodHabit: (Obligatorio) Código de la Habitación.

dFecha : (Obligatorio) Fecha para la cual se desea saber el estado de la habitación.

Comentarios: Devuelve el nombre del cliente si la habitación estuvo ocupada, sino devuelve una cadena vacía.

Ejemplos:


Valor de una Composición en un Periodo

Descripción: Función que devuelve el valor de una composición estadística pasada como parámetro para un periodo determinado.

Sintaxis: = fro_Estad_Periodo(cNombreComposicion,cPeriodo,nEjercicio)

Descripción de Parámetros:

cNombreComposicion: (Obligatorio) Código para reportes de la composición que se quiere calcular.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve el valor calculado para la composición en cuestión. Si la composición no existe devuelve cero. La composición deberá estar previamente creada en el módulo de Inn FrontDesk y con valor el código para reportes de la misma.

Ejemplos:


Valor de una Composición entre Fechas

Descripción: Función que devuelve el valor de una composición estadística pasada como parámetro para un rango de fechas determinado.

Sintaxis: = fro_Estad_Fechas(cNombreComposicion,dFechaDesde,dFechaHasta)

Descripción de Parámetros:

cNombreComposicion: (Obligatorio) Código para reportes de la composición que se quiere calcular.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve el valor calculado para la composición en cuestión. Si la composición no existe devuelve cero. La composición deberá estar previamente creada en el módulo de Inn FrontDesk y con valor el código para reportes de la misma.

Ejemplos:


Hospedaje en un Periodo

Descripción: Función que devuelve el Ingreso de Hospedaje según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: =fro_Ingresos_Hosp_Periodo(cPeriodo,nEjercicio,cTipo_Hab,cAgencia, cMercado, cContrato,cUsoHab,nDirecto,nTasaMonResult)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber el ingreso de hospedaje.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber el ingreso de hospedaje.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber el ingreso de hospedaje.

cContrato: (Opcional) Código del contrato para el cual se desea saber el ingreso de hospedaje.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber el ingreso de hospedaje.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

nTasaMonResult: Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar). Pasar valor 1 si se quiere el resultado en la moneda base de FrontDesk.

Comentarios: Devuelve un valor numérico con el valor del ingreso de hospedaje según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Hospedaje entre Fechas

Descripción: Función que devuelve el Ingreso de Hospedaje según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =fro_Ingresos_Hosp_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia,cMercado,cContrato,cUsoHab,nDirecto,nTasaMonResult)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber el ingreso de hospedaje.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber el ingreso de hospedaje.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber el ingreso de hospedaje.

cContrato: (Opcional) Código del contrato para el cual se desea saber el ingreso de hospedaje.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber el ingreso de hospedaje.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

nTasaMonResult: Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar). Pasar valor 1 si se quiere el resultado en la moneda base de FrontDesk.

Comentarios: Devuelve un valor numérico con el valor del ingreso de hospedaje según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


AyB en un Periodo

Descripción: Función que devuelve el Ingreso de AyB (Alimentos y Bebidas) según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: =fro_Ingresos_AyB_Periodo(cPeriodo,nEjercicio,cTipo_Hab,cAgencia, cMercado, cContrato,cUsoHab,nDirecto,nTasaMonResult)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber el ingreso de hospedaje.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber el ingreso de hospedaje.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber el ingreso de hospedaje.

cContrato: (Opcional) Código del contrato para el cual se desea saber el ingreso de hospedaje.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber el ingreso de hospedaje.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

nTasaMonResult: Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar). Pasar valor 1 si se quiere el resultado en la moneda base de FrontDesk.

Comentarios: Devuelve un valor numérico con el valor del ingreso de AyB según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


AyB entre Fechas

Descripción: Función que devuelve el Ingreso de AyB (Alimentos y Bebidas) según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =fro_Ingresos_AyB_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia,cMercado,cContrato,cUsoHab,nDirecto,nTasaMonResult)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber el ingreso de hospedaje.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber el ingreso de hospedaje.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber el ingreso de hospedaje.

cContrato: (Opcional) Código del contrato para el cual se desea saber el ingreso de hospedaje.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber el ingreso de hospedaje.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda base de FrontDesk.

Comentarios: Devuelve un valor numérico con el valor del ingreso de AyB según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Otros en un Periodo

Descripción: Función que devuelve el Ingreso por Otros Conceptos que no sean Hospedaje y Alimentos & Bebidas, según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: =fro_Ingresos_Otros_Periodo(cPeriodo,nEjercicio,cTipo_Hab,cAgencia, cMercado, cContrato,cUsoHab,nDirecto,nTasaMonResult)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber el ingreso de hospedaje.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber el ingreso de hospedaje.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber el ingreso de hospedaje.

cContrato: (Opcional) Código del contrato para el cual se desea saber el ingreso de hospedaje.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber el ingreso de hospedaje.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

nTasaMonResult: Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar). Pasar valor 1 si se quiere el resultado en la moneda base de FrontDesk.

Comentarios: Devuelve un valor numérico con el valor del ingreso de Otros según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Ejemplos:


Otros entre Fechas

Descripción: Función que devuelve el Ingreso por Otros Conceptos que no sean Hospedaje y Alimentos & Bebidas según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =fro_Ingresos_Otros_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia,cMercado,cContrato,cUsoHab,nDirecto,nTasaMonResult)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber el ingreso de hospedaje.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber el ingreso de hospedaje.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber el ingreso de hospedaje.

cContrato: (Opcional) Código del contrato para el cual se desea saber el ingreso de hospedaje.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber el ingreso de hospedaje.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda base de FrontDesk.

Comentarios: Devuelve un valor numérico con el valor del ingreso de AyB según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Ejemplos:


Entradas en un Periodo

Entradas en un Periodo de Habitaciones

Descripción: Función que devuelve la cantidad de habitaciones que entraron al hotel según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: =fro_Entradas_Habit_Periodo(cPeriodo,nEjercicio,cTipo_Hab,cAgencia, cMercado, cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las entradas.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las entradas.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las entradas.

cContrato: (Opcional) Código del contrato para el cual se desea saber las entradas.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las entradas.

nDirecto:(Obligatorio) 0: Solo las habitaciones de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las entradas. La nacionalidad es la definida en los contratos

Comentarios: Devuelve un valor numérico con la cantidad de habitaciones que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Entradas entre Fechas

Entradas entre Fechas de Habitaciones

Descripción: Función que devuelve la cantidad de habitaciones que entraron al hotel según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =fro_Entradas_Habit_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia,cMercado,cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las entradas.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las entradas.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las entradas.

cContrato: (Opcional) Código del contrato para el cual se desea saber las entradas.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las entradas.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las entradas. La nacionalidad es la definida en los contratos

Comentarios: Devuelve un valor numérico con la cantidad de habitaciones que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Estancias en un Periodo

Estancias en un Periodo de Habitaciones

Descripción: Función que devuelve la cantidad de estancias (noches) de las habitaciones que entraron al hotel según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: =fro_Estancias_Habit_Periodo(cPeriodo,nEjercicio,cTipo_Hab,cAgencia, cMercado, cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las estancias.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las estancias.

cContrato: (Opcional) Código del contrato para el cual se desea saber las estancias.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las estancias.

nDirecto:(Obligatorio) 0: Solo las habitaciones de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las estancias. La nacionalidad es la definida en los contratos

Comentarios: Devuelve un valor numérico con la cantidad de estancias (noches) de las habitaciones que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Estancias entre Fechas

Estancias entre Fechas de Habitaciones

Descripción: Función que devuelve la cantidad de estancias (noches) de las habitaciones que entraron al hotel según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =fro_Estancias_Habit_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia,cMercado,cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las estancias.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las estancias.

cContrato: (Opcional) Código del contrato para el cual se desea saber las estancias.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las estancias.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las estancias. La nacionalidad es la definida en los contratos

Comentarios: Devuelve un valor numérico con la cantidad de estancias (noches) de las habitaciones que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Estancias Futuras en un Periodo

Descripción: Función que devuelve la cantidad de estancias (noches) de las reservas futuras que deben entrar al hotel y de las habitaciones actuales ocupadas según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis:=fro_Estancias_Habit_Futuras_Periodo (cPeriodo, nEjercicio, cTipo_Hab, cAgencia, cMercado, cContrato,cUsoHab,nDirecto, cNacionalidad,nSolic,nConfirm)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las estancias.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las estancias.

cContrato: (Opcional) Código del contrato para el cual se desea saber las estancias.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las estancias.

nDirecto:(Obligatorio) 0: Solo las habitaciones de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las estancias. La nacionalidad es la definida en los contratos

nSolic:(Obligatorio) 0: No tiene en cuenta las reservas en estado solicitado

1: Tiene en cuenta las reservas en estado solicitado

nConfirm:(Obligatorio) 0: No tiene en cuenta las reservas en estado confirmado

1: Tiene en cuenta las reservas en estado confirmado

Comentarios: Devuelve un valor numérico con la cantidad de estancias (noches) de las reservas que deben entrar al hotel y de las habitaciones ocupadas actuales según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.


Estancias Futuras entre Fechas

Descripción: Función que devuelve la cantidad de estancias (noches) de las reservas futuras que deben entrar al hotel y de las habitaciones ocupadas actuales según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis:=fro_Estancias_Habit_Futuras_Fechas (dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia, cMercado, cContrato, cUsoHab, nDirecto, cNacionalidad,nSolic,nConfirm)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las estancias.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las estancias.

cContrato: (Opcional) Código del contrato para el cual se desea saber las estancias.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las estancias.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las estancias. La nacionalidad es la definida en los contratos

nSolic:(Obligatorio) 0: No tiene en cuenta las reservas en estado solicitado

1: Tiene en cuenta las reservas en estado solicitado

nConfirm:(Obligatorio) 0: No tiene en cuenta las reservas en estado confirmado

1: Tiene en cuenta las reservas en estado confirmado

Comentarios: Devuelve un valor numérico con la cantidad de estancias (noches) de las reservas futuras que deben entrar al hotel y de las habitaciones ocupadas actuales según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.


Entradas en un Periodo_Clientes

Entradas en un Periodo de Clientes

Descripción: Función que devuelve la cantidad de clientes que entraron al hotel según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: =fro_Entradas_Clientes_Periodo(cPeriodo,nEjercicio,cTipo_Hab, cAgencia, cMercado, cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las entradas.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las entradas.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las entradas.

cContrato: (Opcional) Código del contrato para el cual se desea saber las entradas.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las entradas.

nDirecto:(Obligatorio) 0: Solo las habitaciones de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las entradas. La nacionalidad es la definida por cliente.

Comentarios: Devuelve un valor numérico con la cantidad de clientes que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Entradas entre Fechas

Entradas entre Fechas de Clientes

Descripción: Función que devuelve la cantidad de clientes que entraron al hotel según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =fro_Entradas_Clientes_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia,cMercado,cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las entradas.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las entradas.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las entradas.

cContrato: (Opcional) Código del contrato para el cual se desea saber las entradas.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las entradas.

nDirecto:(Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las entradas. La nacionalidad es la definida por cliente.

Comentarios: Devuelve un valor numérico con la cantidad de clientes que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Estancias en un Periodo

Estancias en un Periodo de Clientes

Descripción: Función que devuelve la cantidad de estancias por clientes, de los clientes que entraron al hotel según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: =fro_Estancias_Clientes_Periodo(cPeriodo,nEjercicio,cTipo_Hab, cAgencia, cMercado, cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las estancias.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las estancias.

cContrato: (Opcional) Código del contrato para el cual se desea saber las estancias.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las estancias.

nDirecto: (Obligatorio) 0: Solo las habitaciones de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las entradas. La nacionalidad es la definida por cliente.

Comentarios: Devuelve un valor numérico con la cantidad de estancias por clientes de los clientes que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Estancias entre Fechas

Estancias entre Fechas de Clientes

Descripción: Función que devuelve la cantidad de estancias por clientes de los clientes que entraron al hotel según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =fro_Estancias_Clientes_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab, cAgencia,cMercado,cContrato,cUsoHab,nDirecto,cNacionalidad)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab: (Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

cAgencia: (Opcional) Nombre de la Agencia para la cual se desea saber las estancias.

cMercado: (Opcional) Nombre del Mercado para el cual se desea saber las estancias.

cContrato: (Opcional) Código del contrato para el cual se desea saber las estancias.

cUsoHab: (Opcional) Código del uso de habitación para la cual se desea saber las estancias.

nDirecto: (Obligatorio) 0: Solo ingresos de las agencias que no están marcadas como directos.

1: Solo ingresos de las agencias que están marcadas como directos.

-1: Todos los Ingresos. (Directos y no Directos)

cNacionalidad: (Opcional) Código de la nacionalidad para la cual se desea saber las entradas. La nacionalidad es la definida por cliente.

Comentarios: Devuelve un valor numérico con la cantidad de estancias por clientes de los clientes que entraron al hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Nota: Esta función tiene en cuenta que si se le pasa un rango de fechas que contiene días con fecha mayor a la fecha hotelera, los valores serán calculados en base a las reservas y ocupaciones futuras.

Ejemplos:


Entradas en un Periodo

Entradas en un Periodo Fuera de Orden

Descripción: Función que devuelve la cantidad de habitaciones que entraron a fuera de orden (bloqueadas) en el hotel según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: = fro_Entradas_Habit_FOrden_Periodo(cPeriodo,nEjercicio,cTipo_Hab)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las entradas.

Comentarios: Devuelve un valor numérico con la cantidad de habitaciones que entraron a fuera de orden en el hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Ejemplos:


Entradas entre Fechas

Entradas entre Fechas Fuera de Orden

Descripción: Función que devuelve la cantidad de habitaciones que entraron a fuera de orden (bloqueadas) en el hotel según los parámetros de filtrado que se requieran, para un rango de fechas determinado.

Sintaxis:=fro_Entradas_Habit_FOrden_Fechas(dFechaDesde,dFechaHasta,cTipo_Hab)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las entradas.

Comentarios: Devuelve un valor numérico con la cantidad de habitaciones que entraron a fuera de orden en el hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Ejemplos:


Estancias en un Periodo

Estancias en un Periodo Fuera de Orden

Descripción: Función que devuelve la cantidad de estancias (noches) de las habitaciones que entraron a fuera de orden (bloqueadas) en el hotel según los parámetros de filtrado que se requieran, para un periodo determinado.

Sintaxis: = fro_Estancias_Habit_FOrden_Periodo (cPeriodo,nEjercicio,cTipo_Hab)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

Comentarios: Devuelve un valor numérico con la cantidad de estancias (noches) de las habitaciones que entraron a fuera de orden en el hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Ejemplos:


Estancias entre Fechas

Estancias entre Fechas Fuera de Orden

Descripción: Función que devuelve la cantidad de estancias (noches) de las habitaciones que entraron a fuera de orden (bloqueadas) en el hotel según los parámetros de filtrado que se requieran, para un rango de fechas determinado.

Sintaxis:=fro_Estancias_Habit_FOrden_Fechas(dFechaDesde,dFechaHasta, cTipo_Hab)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cTipo_Hab:(Opcional) Código del tipo de habitación para la cual se desea saber las estancias.

Comentarios: Devuelve un valor numérico con la cantidad de estancias (noches) habitaciones que entraron a fuera de orden en el hotel según los parámetros de filtrado que se la pasen a la función. Si alguno de los parámetros no es válido o no se encuentra en la configuración, se devuelve cero.

Ejemplos:


Descripción de un Punto de Venta dado su Código

Descripción: Función que devuelve la descripción de un punto de venta dado su código.

Sintaxis: =pos_Desc_Pvta(cCodPvta,cBaseDatos)

Descripción de Parámetros:

cCodPvta: (Obligatorio) Código del punto de venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej "Tienda ", "Boutique", etc.

Comentarios: Devuelve la descripción del punto de venta dado su código. Si no existe devuelve una cadena vacía.

Ejemplos:


Descripción de un Artículo de Venta dado su Código

Descripción: Función que devuelve la descripción de un artículo de venta dado su código.

Sintaxis: =pos_Desc_Arti(cCodArti,cBaseDatos)

Descripción de Parámetros:

cCodArti: (Obligatorio) Código del artículo de venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve la descripción del artículo de venta dado su código. Si no existe devuelve una cadena vacía.


por Familia en un Periodo

Ventas por Familia en un Periodo

Descripción: Función que calcula las ventas de una familia dada su descripción, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Ventas_Familia_Periodo(cFamilia,cCodPvta,cPeriodo,nEjercicio, cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cFamilia: (Obligatorio) Descripción del Familia para la cual se desea calcular las ventas.

cCodPvta: (Opcional) Código del punto de venta.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas de la familia pasada como parámetro. Si no existe la familia, devuelve cero.

Ejemplos:


por Familia entre Fechas

Ventas por Familia entre Fechas

Descripción: Función que calcula las ventas de una familia dada su descripción, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Ventas_Familia_Fechas(cFamilia,cCodPvta, dFechaDesde, dFechaHasta, cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cFamilia: (Obligatorio) Descripción del Familia para la cual se desea calcular las ventas.

cCodPvta: (Opcional) Código del punto de venta.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas de la familia pasada como parámetro. Si no existe la familia, devuelve cero.

Ejemplos:


por SubFamilia en un Periodo

Ventas por SubFamilia en un Periodo

Descripción: Función que calcula las ventas de una subfamilia dada su descripción, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Ventas_SubFamilia_Periodo(cSubFamilia,cCodPvta,cPeriodo,nEjercicio, cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cSubFamilia: (Obligatorio) Descripción del SubFamilia para la cual se desea calcular las ventas.

cCodPvta: (Opcional) Código del punto de venta.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas de la Subfamilia pasada como parámetro. Si no existe la Subfamilia, devuelve cero.

Ejemplos:


por SubFamilia entre Fechas

Ventas por SubFamilia entre Fechas

Descripción: Función que calcula las ventas de una Subfamilia dada su descripción, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Ventas_SubFamilia_Fechas(cFamilia,cCodPvta, dFechaDesde, dFechaHasta, cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cFamilia: (Obligatorio) Descripción del SubFamilia para la cual se desea calcular las ventas.

cCodPvta: (Opcional) Código del punto de venta.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas de la Subfamilia pasada como parámetro. Si no existe la familia, devuelve cero.

Ejemplos:


por Artículo en un Periodo

Ventas por Artículo en un Periodo

Descripción: Función que calcula las ventas de un artículo(s) dado su código, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Ventas_Articulo_Periodo(cCodArti,cCodPvta,cPeriodo, nEjercicio, cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cCodArti: (Obligatorio) Código del Artículo para el cual se desea calcular las ventas. Se puede pasar también una subcadena de los caracteres con los que comienza el código del artículo y en este caso la función sumará todos los artículos que comiencen con esta. Ej: Cod de Artículo: 101001, 101002, 101003, si yo quisiera saber las ventas de todos los artículos que comiencen con 101, pasaría en este parámetro: "101"

cCodPvta: (Opcional) Código del punto de venta.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas del artículo(s) pasado como parámetro. Si no existe el artículo, devuelve cero.

Ejemplos:


por Artículo entre Fechas

Ventas por Artículo entre Fechas

Descripción: Función que calcula las ventas de un Artículo(s) dado su código, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Ventas_Articulo_Fechas(cCodArti,cCodPvta,dFechaDesde, dFechaHasta,cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cCodArti: (Obligatorio) Código del Artículo para el cual se desea calcular las ventas. Se puede pasar también una subcadena de los caracteres con los que comienza el código del artículo y en este caso la función sumará todos los artículos que comiencen con esta. Ej: Cod de Artículo: 101001, 101002, 101003, si yo quisiera saber las ventas de todos los artículos que comiencen con 101, pasaría en este parámetro: "101"

cCodPvta: (Opcional) Código del punto de venta.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas del Artículo(s) pasado como parámetro. Si no existe el Artículo, devuelve cero.

Ejemplos:


por Punto de Venta en un Periodo

Ventas por Punto de Venta en un Periodo

Descripción: Función que calcula las ventas de un Punto de Venta dado su código, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Ventas_Pvta_Periodo(cCodPvta,cDescServicio,cPeriodo,nEjercicio, cMoneda , nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cCodPvta: (Obligatorio) Código del punto de venta para el cual se desea calcular las ventas.

cDescServicio: (Opcional) Descripción del Servicio en que se realizó la venta.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas del Punto de Venta pasado como parámetro. Si no existe el Punto de Venta, devuelve cero.

Ejemplos:


por Punto de Venta entre Fechas

Ventas por Punto de Venta entre Fechas

Descripción: Función que calcula las ventas de un Punto de Venta dado su código, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Ventas_Pvta_Fechas(cCodPvta,cDescServicio,dFechaDesde, dFechaHasta,cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cCodPvta: (Obligatorio) Código del punto de venta para el cual se desea calcular las ventas.

cDescServicio: (Opcional) Descripción del Servicio en que se realizó la venta.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas del Punto de Venta pasado como parámetro. Si no existe el Punto de Venta, devuelve cero.

Ejemplos:


por Servicio en un Periodo

Ventas por Servicio en un Periodo

Descripción: Función que calcula las ventas de un Servicio dado su descripción, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Ventas_Servicio_Periodo(cDescServicio,cPeriodo,nEjercicio, cMoneda, nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cDescServicio: (Obligatorio) Descripción del Servicio en que se realizó la venta.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas del Servicio pasado como parámetro. Si no existe el Servicio, devuelve cero.

Ejemplos:


por Servicio entre Fechas

Ventas por Servicio entre Fechas

Descripción: Función que calcula las ventas de un Servicio dado su descripción, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Ventas_Servicio_Fechas(cCodPvta,cDescServicio, dFechaDesde, dFechaHasta, cMoneda , nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cDescServicio: (Obligatorio) Descripción del Servicio en que se realizó la venta.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas del Servicio pasado como parámetro. Si no existe el Servicio, devuelve cero.

Ejemplos:


Totales en un Periodo

Ventas Totales en un Periodo

Descripción: Función que calcula las ventas Totales de los Puntos de Ventas para un periodo pasado como parámetro.

Sintaxis: =pos_Ventas_Totales_Periodo(cPeriodo,nEjercicio,cMoneda, nTasaMonResult, cBaseDatos)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas totales de los puntos de venta.

Ejemplos:


Totales entre Fechas

Ventas Totales entre Fechas

Descripción: Función que calcula las ventas totales de los puntos de venta, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Ventas_Totales_Fechas(dFechaDesde, dFechaHasta, cMoneda , nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con las ventas totales de los puntos de venta.

Ejemplos:


por Familia en un Periodo

Descuentos por Familia en un Periodo

Descripción: Función que calcula los descuentos de una familia dada su descripción, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Dcto_Familia_Periodo(cFamilia,cCodPvta,cPeriodo,nEjercicio, cMoneda, nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cFamilia: (Obligatorio) Descripción del Familia para la cual se desea calcular los descuentos.

cCodPvta: (Opcional) Código del punto de venta.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con los descuentos de la familia pasada como parámetro. Si no existe la familia, devuelve cero.

Ejemplos:


por Familia entre Fechas

Descuentos por Familia entre Fechas

Descripción: Función que calcula los descuentos de una familia dada su descripción, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Dcto_Familia_Fechas(cFamilia,cCodPvta, dFechaDesde, dFechaHasta, cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cFamilia: (Obligatorio) Descripción del Familia para la cual se desea calcular los descuentos.

cCodPvta: (Opcional) Código del punto de venta.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con los descuentos de la familia pasada como parámetro. Si no existe la familia, devuelve cero.

Ejemplos:


por Familia en un Periodo

Recargos por Familia en un Periodo

Descripción: Función que calcula los recargos de una familia dada su descripción, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Recargo_Familia_Periodo(cFamilia,cCodPvta,cPeriodo,nEjercicio, cMoneda, nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cFamilia: (Obligatorio) Descripción del Familia para la cual se desea calcular los recargos.

cCodPvta: (Opcional) Código del punto de venta.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con los recargos de la familia pasada como parámetro. Si no existe la familia, devuelve cero.

Ejemplos:


por Familia entre Fechas

Recargos por Familia entre Fechas

Descripción: Función que calcula los recargos de una familia dada su descripción, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Recargo_Familia_Fechas(cFamilia,cCodPvta, dFechaDesde, dFechaHasta, cMoneda,nTasaMonResult,cBaseDatos)

Descripción de Parámetros:

cFamilia: (Obligatorio) Descripción del Familia para la cual se desea calcular los recargos.

cCodPvta: (Opcional) Código del punto de venta.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cMoneda: (Obligatorio) Código de la moneda en la que se expresará el resultado.

Ej: "COL", "USD", etc.

nTasaMonResult: (Obligatorio) Tasa de conversión para la moneda en que se quiere expresar el resultado. (Siempre para multiplicar) .Pasar valor 1 si se quiere el resultado en la moneda de Facturación del Punto de Venta.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con los recargos de la familia pasada como parámetro. Si no existe la familia, devuelve cero.

Ejemplos:


Cantidad de Artículos Vendidos en un Periodo

Descripción: Función que calcula la cantidad de vendida de un artículo(s) dado su código, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Cant_Articulo_Periodo(cCodArti,cCodPvta,cDescServicio,cPeriodo, nEjercicio,nIncluyeCCasa,cBaseDatos)

Descripción de Parámetros:

cCodArti: (Obligatorio) Código del Artículo para el cual se desea calcular la cantidad vendida. Se puede pasar también una subcadena de los caracteres con los que comienza el código del artículo y en este caso la función sumará todos los artículos que comiencen con esta. Ej: Cod de Artículo: 101001, 101002, 101003, si yo quisiera saber la cantidad vendidad de todos los artículos que comiencen con 101, pasaría en este parámetro: "101"

cCodPvta: (Opcional) Código del punto de venta.

cDescServicio: (Opcional) Descripción del Servicio.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

nIncluyeCCasa: (Obligatorio) Indica si quieren contar los artículos que se facturaron en folios cuenta casa.

0: Que no se incluyan

1: Que se incluyan.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con la cantidad vendida del artículo(s) pasado como parámetro. Si no existe el artículo, devuelve cero.

Ejemplos:


Cantidad de Artículos Vendidos entre Fechas

Descripción: Función que calcula la cantidad de vendida de un artículo(s) dado su código, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Cant_Articulo_Fechas(cCodArti,cCodPvta, cDescServicio, dFechaDesde, dFechaHasta, nIncluyeCCasa, cBaseDatos)

Descripción de Parámetros:

cCodArti: (Obligatorio) Código del Artículo para el cual se desea calcular la cantidad vendida. Se puede pasar también una subcadena de los caracteres con los que comienza el código del artículo y en este caso la función sumará todos los artículos que comiencen con esta. Ej: Cod de Artículo: 101001, 101002, 101003, si yo quisiera saber la cantidad vendidad de todos los artículos que comiencen con 101, pasaría en este parámetro: "101"

cCodPvta: (Opcional) Código del punto de venta.

cDescServicio: (Opcional) Descripción del Servicio.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

nIncluyeCCasa: (Obligatorio) Indica si quieren contar los artículos que se facturaron en folios cuenta casa.

0: Que no se incluyan

1: Que se incluyan.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con la cantidad vendida del artículo(s) pasado como parámetro. Si no existe el artículo, devuelve cero.


Total de Clientes en un Periodo

Descripción: Función que calcula la cantidad de clientes que consumieron en los puntos de ventas, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Tot_Clientes_Periodo(cCodPvta,cDescServicio,cCodNacionalidad, cPeriodo,nEjercicio,nIncluyeCCasa,cBaseDatos)

Descripción de Parámetros:

cCodPvta: (Opcional) Código del punto de venta.

cDescServicio: (Opcional) Descripción del Servicio.

cCodNacionalidad: (Opcional) Código de la Nacionalidad del Cliente.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

nIncluyeCCasa: (Obligatorio) Indica si quieren contar los artículos que se facturaron en folios cuenta casa.

0: Que no se incluyan

1: Que se incluyan.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con la cantidad de clientes que consumieron en los puntos de ventas.

Ejemplos:


Total de Clientes entre Fechas

Descripción: Función que calcula la cantidad de clientes que consumieron en los puntos de ventas, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Tot_Clientes_Fechas(cCodPvta,cDescServicio,cCodNacionalidad, dFechaDesde, dFechaHasta,nIncluyeCCasa,cBaseDatos)

Descripción de Parámetros:

cCodPvta: (Opcional) Código del punto de venta.

cDescServicio: (Opcional) Descripción del Servicio.

cCodNacionalidad: (Opcional) Código de la Nacionalidad del Cliente.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

nIncluyeCCasa: (Obligatorio) Indica si quieren contar los artículos que se facturaron en folios cuenta casa.

0: Que no se incluyan

1: Que se incluyan.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con la cantidad de clientes que consumieron en los puntos de ventas.

Ejemplos:


Total de Huéspedes en un Periodo

Descripción: Función que calcula la cantidad de Huéspedes que consumieron en los puntos de ventas, según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =pos_Tot_ Huespedes_Periodo(cCodPvta,cDescServicio, cCodNacionalidad, cPeriodo,nEjercicio,nIncluyeCCasa,cBaseDatos)

Descripción de Parámetros:

cCodPvta: (Opcional) Código del punto de venta.

cDescServicio: (Opcional) Descripción del Servicio.

cCodNacionalidad: (Opcional) Código de la Nacionalidad del Cliente.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

nIncluyeCCasa: (Obligatorio) Indica si quieren contar los artículos que se facturaron en folios cuenta casa.

0: Que no se incluyan

1: Que se incluyan.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con la cantidad de Huéspedes que consumieron en los puntos de ventas.

Ejemplos:


Total de Huéspedes entre Fechas

Descripción: Función que calcula la cantidad de Huéspedes que consumieron en los puntos de ventas, según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =pos_Tot_Huespedes_Fechas(cCodPvta,cDescServicio, cCodNacionalidad, dFechaDesde, dFechaHasta, nIncluyeCCasa,cBaseDatos)

Descripción de Parámetros:

cCodPvta: (Opcional) Código del punto de venta.

cDescServicio: (Opcional) Descripción del Servicio.

cCodNacionalidad: (Opcional) Código de la Nacionalidad del Cliente.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

nIncluyeCCasa: (Obligatorio) Indica si quieren contar los artículos que se facturaron en folios cuenta casa.

0: Que no se incluyan

1: Que se incluyan.

cBaseDatos: (Opcional) Nombre de la base de datos en la que esta configurado el punto de venta. Por defecto, se puede pasar vacío (""), en cuyo caso se haría referencia a la base datos por defecto ("InnPos"). Solo sería necesario cuando en el hotel existan distintas bases de datos de puntos de venta: Ej: "Tienda ", "Boutique", etc.

Comentarios: Devuelve un valor numérico con la cantidad de Huéspedes que consumieron en los puntos de ventas.

Ejemplos:


Título de una Cuenta dado su Código

Descripción: Función que devuelve el título de una cuenta dado su código.

Sintaxis: =acc_Titulo_Cuenta(cCuenta,cEmpresa)

Descripción de Parámetros:

cCuenta: (Obligatorio) Código de la Cuenta contable.

cEmpresa: (Obligatorio) Código de la empresa contable donde está creada la cuenta. Por defecto se pasará "001".

Comentarios: Devuelve el título de una cuenta contable dado su código. Si no existe devuelve una cadena vacía.

Ejemplos:


Título de un Centro de Costo/Gasto dado su Código

Descripción: Función que devuelve el título de un centro de costo/gasto dado su código.

Sintaxis: =acc_Titulo_CtoGto(cCto/Gto,cEmpresa)

Descripción de Parámetros:

cCto/Gto: (Obligatorio) Código del centro de costo/gasto.

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

Comentarios: Devuelve el título de un centro de costo/gasto dado su código. Si no existe devuelve una cadena vacía.

Ejemplos:


Título de una Empresa dado su Código

Descripción: Función que devuelve el título de una empresa contable dado su código.

Sintaxis: =acc_Titulo_Empresa(cEmpresa)

Descripción de Parámetros:

cEmpresa: (Obligatorio) Código de la empresa contable.

Comentarios: Devuelve el título de la empresa contable dado su código. Si no existe devuelve una cadena vacía.

Ejemplos:


Saldo en un Periodo

Saldo de una Cuenta en un Periodo

Descripción: Función que calcula el saldo de una cuenta(s), según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =acc_Saldo_Cuenta_Periodo(cCuenta,cCto/Gto,cPeriodo,nEjercicio, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su saldo. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el saldo de la cuenta(s) pasada como parámetro. Si la cuenta no existe devuelve cero.

Ejemplos:


Saldo entre Fechas

Saldo de una Cuenta entre Fechas

Descripción: Función que calcula el saldo de una cuenta(s), según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =acc_Saldo_Cuenta_Fechas(cCuenta,cCto/Gto, dFechaDesde, dFechaHasta, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su saldo. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el saldo de la cuenta(s) pasada como parámetro. Si la cuenta no existe devuelve cero.

Ejemplos:


Saldo hasta un Periodo

Saldo de una Cuenta hasta un Periodo (Acumulado)

Descripción: Función que calcula el saldo acumulado de una cuenta(s), según los parámetros de filtrado que se requieran, hasta un periodo pasado como parámetro.

Sintaxis: =acc_Acum_Cuenta_Periodo(cCuenta,cCto/Gto,cPeriodo,nEjercicio, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su saldo. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal hasta el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el saldo acumulado de la cuenta(s) pasada como parámetro hasta un periodo. Si la cuenta no existe devuelve cero.

Ejemplos:


Importe Pendiente en un Periodo

Descripción: Función que calcula el importe pendiente de aplicar de una cuenta(s), según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =acc_Saldo_Cuenta_Periodo_Pend(cCuenta,cCto/Gto,cPeriodo, nEjercicio, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su saldo. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el saldo pendiente de aplicar de la cuenta(s) pasada como parámetro. Si la cuenta no existe devuelve cero.

Ejemplos:


Importe Pendiente entre Fechas

Descripción: Función que calcula el saldo pendiente de aplicar de una cuenta(s), según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =acc_Saldo_Cuenta_Fechas_Pend(cCuenta,cCto/Gto, dFechaDesde, dFechaHasta, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su saldo. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el saldo pendiente de aplicar de la cuenta(s) pasada como parámetro. Si la cuenta no existe devuelve cero.

Ejemplos:


Importe Pendiente hasta un Periodo

Descripción: Función que calcula el saldo acumulado pendiente de aplicar de una cuenta(s), según los parámetros de filtrado que se requieran, hasta un periodo pasado como parámetro.

Sintaxis: =acc_Acum_Cuenta_Periodo_Pend(cCuenta,cCto/Gto,cPeriodo, nEjercicio, cEmpresa, cMoneda, nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su saldo. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal hasta el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el saldo acumulado pendiente de aplicar de la cuenta(s) pasada como parámetro hasta un periodo. Si la cuenta no existe devuelve cero.

Ejemplos:


Para una Cuenta en un Periodo

Presupuesto Para una Cuenta en un Periodo

Descripción: Función que calcula el presupuesto de una cuenta(s), según los parámetros de filtrado que se requieran, para un periodo pasado como parámetro.

Sintaxis: =acc_Saldo_Presu_Periodo(cCuenta,cCto/Gto,cPeriodo, nEjercicio, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su presupuesto. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el presupuesto de la cuenta(s) pasada como parámetro. Si la cuenta no existe devuelve cero.

Ejemplos:


Para una Cuenta entre Fechas

Presupuesto Para una Cuenta entre Fechas

Descripción: Función que calcula el presupuesto de una cuenta(s), según los parámetros de filtrado que se requieran, para un rango de fechas pasado como parámetro.

Sintaxis: =acc_Saldo_Presu_Fechas(cCuenta,cCto/Gto,dFechaDesde, dFechaHasta, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su presupuesto. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el presupuesto de la cuenta(s) pasada como parámetro. Si la cuenta no existe devuelve cero.

Ejemplos:


Saldo para una Cuenta hasta un Periodo

Presupuesto para una Cuenta hasta un Periodo

Descripción: Función que calcula el presupuesto de una cuenta(s), según los parámetros de filtrado que se requieran, hasta el periodo pasado como parámetro.

Sintaxis: = acc_Acum_Presu_Periodo(cCuenta,cCto/Gto,cPeriodo, nEjercicio, cEmpresa, cMoneda,nTasaMonBase,nTasaMonResult)

Descripción de Parámetros:

cCuenta: (Opcional) Código de la cuenta contable para la cual se desea conocer su presupuesto. Se puede pasar también una subcadena de los caracteres con los que comienza el código de la cuenta y en este caso la función sumará todos los saldos de las cuentas que comiencen con esta subcadena. Ej: Cuentas: 10101001, 10101002, 10101003, si yo quisiera saber el saldo de todas las cuenta 101 pasaría en este parámetro: "101", si quisiera saber el saldo de la cuenta 10101003 entonces pasaría: "10101003"

cCto/Gto: (opcional) Código del centro de costo/gasto.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cEmpresa: (Obligatorio) Código de la empresa contable donde está creado el centro de costo/gasto. Por defecto se pasará "001".

cMoneda: (Obligatorio) Moneda en la que se expresará el resultado de la función. Ej: "COL", "USD"

nTasaMonBase: (Obligatorio): Tipo de Cambio en FrontDesk de la moneda base de la contabilidad. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para dividir)

nTasaMonResult: (Obligatorio) Tipo de Cambio en FrontDesk de la moneda en la que se expresará el resultado. Si se pasa valor cero, se asume el valor actual que está configurado en InnSuite. (Este valor se usa para multiplicar)

Comentarios: Devuelve un valor numérico con el presupuesto de la cuenta(s) pasada como parámetro hasta el periodo seleccionado. Si la cuenta no existe devuelve cero.

Ejemplos:


desde Extensiones en un Periodo

Importe de Llamadas desde Extensiones en un Periodo

Descripción: Función que calcula el importe de las llamadas telefónicas realizadas desde un extensión(s), según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Importe_Extension_Periodo(cCodExte,cPeriodo,nEjercicio, cCodArea)

Descripción de Parámetros:

cCodExte: (Obligatorio) Código de la extensión telefónica para la cual se desea conocer el importe de sus llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza la extensión telefónica y en este caso la función sumará todos los importes de llamadas de las extensiones telefónicas que comiencen con esta subcadena. Ej: Extensión: 620, 621, 622, si yo quisiera saber el importe de las llamadas de la extensiones que comiencen con 6 pasaría en este parámetro: "6", si quisiera saber el importe de las llamadas de la extensión 622 entonces pasaría: "622"

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el importe de las llamadas telefónicas realizadas desde la extensión(s) pasada como parámetro. Si la extensión no existe devuelve cero.

Ejemplos:


desde Extensiones entre Fechas

Importe de Llamadas desde Extensiones entre Fechas

Descripción: Función que calcula el importe de las llamadas telefónicas realizadas desde un extensión(s), según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Importe_Extension_Fechas(cCodExte, dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

cCodExte: (Obligatorio) Código de la extensión telefónica para la cual se desea conocer el importe de sus llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza la extensión telefónica y en este caso la función sumará todos los importes de llamadas de las extensiones telefónicas que comiencen con esta subcadena. Ej: Extensión: 620, 621, 622, si yo quisiera saber el importe de las llamadas de la extensiones que comiencen con 6 pasaría en este parámetro: "6", si quisiera saber el importe de las llamadas de la extensión 622 entonces pasaría: "622"

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el importe de las llamadas telefónicas realizadas desde la extensión(s) pasada como parámetro. Si la extensión no existe devuelve cero.


desde Extensiones Cobrables en un Periodo

Importe de Llamadas desde Extensiones Cobrables en un Periodo

Descripción: Función que calcula el importe de las llamadas telefónicas realizadas desde extensiones cobrables, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: = com_Importe_Cobrables_Periodo (cPeriodo, nEjercicio, cCodArea)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el importe de las llamadas telefónicas realizadas desde extensiones cobrables.

Ejemplos:


desde Extensiones Cobrables entre Fechas

Importe de Llamadas desde Extensiones Cobrables entre Fechas

Descripción: Función que calcula el importe de las llamadas telefónicas realizadas desde extensiones cobrables, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: = com_Importe_Cobrables_Fechas(dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el importe de las llamadas telefónicas realizadas desde extensiones cobrables.

Ejemplos:


desde un Grupo de Tarifa en un Periodo

Descripción: Función que calcula el importe de las llamadas telefónicas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Importe_GrupoTarifa_Periodo(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve un valor numérico con el importe de las llamadas telefónicas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


desde un Grupo de Tarifa entre Fechas

Descripción: Función que calcula el importe de las llamadas telefónicas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Importe_GrupoTarifa_Fechas(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve un valor numérico con el importe de las llamadas telefónicas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


desde Extensiones en un Periodo

Costo de Llamadas desde Extensiones en un Periodo

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas desde un extensión(s), según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: = =com_Costo_Extension_Periodo(cCodExte,cPeriodo,nEjercicio, cCodArea)

Descripción de Parámetros:

cCodExte: (Obligatorio) Código de la extensión telefónica para la cual se desea conocer el costo de sus llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza la extensión telefónica y en este caso la función sumará todos los costo de llamadas de las extensiones telefónicas que comiencen con esta subcadena. Ej: Extensión: 620, 621, 622, si yo quisiera saber el costo de las llamadas de la extensiones que comiencen con 6 pasaría en este parámetro: "6", si quisiera saber el costo de las llamadas de la extensión 622 entonces pasaría: "622"

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas realizadas desde la extensión(s) pasada como parámetro. Si la extensión no existe devuelve cero.

Ejemplos:


desde Extensiones entre Fechas

Costo de Llamadas desde Extensiones entre Fechas

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas desde un extensión(s), según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: = =com_Costo_Extension_Fechas(cCodExte, dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

cCodExte: (Obligatorio) Código de la extensión telefónica para la cual se desea conocer el costo de sus llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza la extensión telefónica y en este caso la función sumará todos los costo de llamadas de las extensiones telefónicas que comiencen con esta subcadena. Ej: Extensión: 620, 621, 622, si yo quisiera saber el importe de las llamadas de la extensiones que comiencen con 6 pasaría en este parámetro: "6", si quisiera saber el costo de las llamadas de la extensión 622 entonces pasaría: "622"

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas realizadas desde la extensión(s) pasada como parámetro. Si la extensión no existe devuelve cero.

Ejemplos:


desde Extensiones Cobrables en un Periodo

Costo de Llamadas desde Extensiones Cobrables en un Periodo

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas desde extensiones cobrables, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: = com_Costo_Cobrables_Periodo (cPeriodo, nEjercicio, cCodArea)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas realizadas desde extensiones cobrables.

Ejemplos:


desde Extensiones Cobrables entre Fechas

Costo de Llamadas desde Extensiones Cobrables entre Fechas

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas desde extensiones cobrables, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: = com_Costo_Cobrables_Fechas(dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el Costo de las llamadas telefónicas realizadas desde extensiones cobrables.

Ejemplos:


desde Extensiones No Cobrables en un Periodo

Costo de Llamadas desde Extensiones No Cobrables en un Periodo

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas desde extensiones no cobrables, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: = com_Costo_NoCobrables_Periodo (cPeriodo, nEjercicio, cCodArea)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas realizadas desde extensiones no cobrables.

Ejemplos:


desde Extensiones No Cobrables entre Fechas

Costo de Llamadas desde Extensiones No Cobrables entre Fechas

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas desde extensiones no cobrables, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: = com_Costo_NoCobrables_Fechas(dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con el Costo de las llamadas telefónicas realizadas desde extensiones no cobrables.

Ejemplos:


desde un Grupo de Tarifa en un Periodo_Costos

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Costo_GrupoTarifa_Periodo(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


desde un Grupo de Tarifa entre Fechas

Descripción: Función que calcula el costo de las llamadas telefónicas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Costo_GrupoTarifa_Fechas(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


desde un Grupo de Tarifa Cobradas en un Periodo

Descripción: Función que calcula el costo de las llamadas telefónicas cobradas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Costo_GrupoTarifa_Cobradas_Periodo(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas cobradas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


desde un Grupo de Tarifa Cobradas entre Fechas

Descripción: Función que calcula el costo de las llamadas telefónicas cobradas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Costo_GrupoTarifa_Cobradas_Fechas(cGrupoTarifa,dFechaDesde,dFechaHasta)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas cobradas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


desde un Grupo de Tarifa No Cobradas en un Periodo_Costos

Descripción: Función que calcula el costo de las llamadas telefónicas no cobradas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Costo_GrupoTarifa_NoCobradas_Periodo(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas no cobradas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


desde un Grupo de Tarifa No Cobradas entre Fechas

Descripción: Función que calcula el costo de las llamadas telefónicas no cobradas realizadas que se tarifaron por un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Costo_GrupoTarifa_NoCobradas_Fechas(cGrupoTarifa,dFechaDesde,dFechaHasta)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve un valor numérico con el costo de las llamadas telefónicas no cobradas realizadas desde el grupo de tarifas pasado como parámetro. Si el grupo de tarifa no existe devuelve cero.


en Minutos desde Extensiones en un Periodo

Duración en Minutos desde Extensiones en un Periodo

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas realizadas desde una extensión(s), según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Cant_Minutos_Extension_Periodo(cCodExte,cPeriodo,nEjercicio, cCodArea)

Descripción de Parámetros:

cCodExte: (Obligatorio) Código de la extensión telefónica para la cual se desea conocer la cantidad de minutos de sus llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza la extensión telefónica y en este caso la función sumará todos los minutos de llamadas de las extensiones telefónicas que comiencen con esta subcadena. Ej: Extensión: 620, 621, 622, si yo quisiera saber la cantidad de minutos de las llamadas de las extensiones que comiencen con 6 pasaría en este parámetro: "6", si quisiera saber la cantidad de minutos de las llamadas de la extensión 622 entonces pasaría: "622"

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas realizadas desde la extensión(s) pasada como parámetro. Si la extensión no existe devuelve cero.

Ejemplos:


en Minutos desde Extensiones entre Fechas

Duración en Minutos desde Extensiones entre Fechas

Descripción: Función que calcula cantidad de minutos de las llamadas telefónicas realizadas desde una extensión(s), según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: : =com_Cant_Minutos_Extension_Fechas(cCodExte,dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

cCodExte: (Obligatorio) Código de la extensión telefónica para la cual se desea conocer cantidad de minutos de sus llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza la extensión telefónica y en este caso la función sumará todos los minutos de llamadas de las extensiones telefónicas que comiencen con esta subcadena. Ej: Extensión: 620, 621, 622, si yo quisiera saber cantidad de minutos de las llamadas de la extensiones que comiencen con 6 pasaría en este parámetro: "6", si quisiera saber cantidad de minutos de las llamadas de la extensión 622 entonces pasaría: "622"

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas realizadas desde la extensiones cobrables.

Ejemplos:


en Minutos desde Extensiones Cobrables en un Periodo

Duración en Minutos desde Extensiones Cobrables en un Periodo

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas realizadas desde extensiones cobrables, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Cant_Minutos_Cobrables_Periodo (cPeriodo,nEjercicio, cCodArea)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas realizadas desde extensiones cobrables.

Ejemplos:


en Minutos desde Extensiones Cobrables entre Fechas

Duración en Minutos desde Extensiones Cobrables entre Fechas

Descripción: Función que calcula cantidad de minutos de las llamadas telefónicas realizadas desde un extensiones cobrables, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: : =com_Cant_Minutos_Cobrables_Fechas(dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con cantidad de minutos de las llamadas telefónicas realizadas desde extensiones cobrables.


en Minutos desde Extensiones No Cobrables en un Periodo

Duración en Minutos desde Extensiones No Cobrables en un Periodo

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas realizadas desde extensiones no cobrables, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Cant_Minutos_NoCobrables_Periodo (cPeriodo,nEjercicio, cCodArea)

Descripción de Parámetros:

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas realizadas desde extensiones no cobrables.

Ejemplos:


en Minutos desde Extensiones No Cobrables entre Fechas

Duración en Minutos desde Extensiones No Cobrables entre Fechas

Descripción: Función que calcula cantidad de minutos de las llamadas telefónicas realizadas desde un extensiones no cobrables, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: : =com_Cant_Minutos_NoCobrables_Fechas(dFechaDesde, dFechaHasta, cCodArea)

Descripción de Parámetros:

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

cCodArea: (Opcional) Código del área geográfica a donde se realizaron las llamadas. Se puede pasar también una subcadena de los caracteres con los que comienza el área geográfica y en este caso la función sumará todos las llamadas realizadas a áreas geográficas que comiencen con esta subcadena. Ej: Aréa: 001, 0052, 00501, 00506, si yo quisiera saber las llamadas realizadas a áreas geográficas que comiencen con 00 pasaría en este parámetro: "00", si quisiera saber las llamadas realizadas al área geográfica 0052 entonces pasaría: "0052".

Comentarios: Devuelve un valor numérico con cantidad de minutos de las llamadas telefónicas realizadas desde extensiones no cobrables.


en Minutos desde un Grupo de Tarifa en un Periodo

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas realizadas desde un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Cant_Minutos_GrupoTarifa_Periodo(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas realizadas desde el grupo de tarifas pasado como parámetro.


en Minutos desde un Grupo de Tarifa entre Fechas

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas realizadas desde un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Cant_Minutos_GrupoTarifa_Fechas(cGrupoTarifa,dFechaDesde,dFechaHasta)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas realizadas desde el grupo de tarifas pasado como parámetro.


en Minutos Cobrados desde un Grupo de Tarifa en un Periodo

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas cobradas realizadas desde un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Cant_Minutos_GrupoTarifa_Cobrados_Periodo(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas cobradas realizadas desde el grupo de tarifas pasado como parámetro.


en Minutos Cobrados desde un Grupo de Tarifa entre Fechas

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas cobradas realizadas desde un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Cant_Minutos_GrupoTarifa_Cobrados_Fechas(cGrupoTarifa,dFechaDesde,dFechaHasta)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas cobradas realizadas desde el grupo de tarifas pasado como parámetro.


en Minutos No Cobrados desde un Grupo de Tarifa en un Periodo

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas no cobradas realizadas desde un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el periodo pasado como parámetro.

Sintaxis: =com_Cant_Minutos_GrupoTarifa_NoCobrados_Periodo(cGrupoTarifa,cPeriodo,nEjercicio)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

cPeriodo: (Obligatorio) Periodo del ejercicio fiscal para el cual se desea realizar el cálculo. Ej. ("Enero", "Febrero", "Marzo", etc.)

nEjercicio: (Obligatorio) Ejercicio fiscal para el cual se desea realizar el cálculo. Ej. (2003, 2004, 2005, 2006)

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas nocobradas realizadas desde el grupo de tarifas pasado como parámetro.


en Minutos No Cobrados desde un Grupo de Tarifa entre Fechas

Descripción: Función que calcula la cantidad de minutos de las llamadas telefónicas no cobradas realizadas desde un grupo de tarifas específico, según los parámetros de filtrado que se requieran, para el rango de fechas pasado como parámetro.

Sintaxis: =com_Cant_Minutos_GrupoTarifa_NoCobrados_Fechas(cGrupoTarifa,dFechaDesde,dFechaHasta)

Descripción de Parámetros:

cGrupoTarifa: (Obligatorio) Descripción del grupo de tarifas para la cual se desea conocer el importe de sus llamadas. Si se pasa vacío entonces calcula para todos los grupos.

dFechaDesde: (Obligatorio) Fecha de inicio para el cual se desea realizar el cálculo. ("12/20/2004")

dFechaHasta: (Obligatorio) Fecha final para el cual se desea realizar el cálculo. ("12/31/2004")

Comentarios: Devuelve un valor numérico con la cantidad de minutos de las llamadas telefónicas no cobradas realizadas desde el grupo de tarifas pasado como parámetro.